summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2014-12-24 07:15:18 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2014-12-24 07:15:18 +0000
commit4d12f60993f84329e28ca7e083a76fb459684cf2 (patch)
treef83ab11af2be69ea10e6a446c6db70338bf5d69f /sys-apps
parentbump; add pypy3, update license noted by Arfrever (diff)
downloadgentoo-2-4d12f60993f84329e28ca7e083a76fb459684cf2.tar.gz
gentoo-2-4d12f60993f84329e28ca7e083a76fb459684cf2.tar.bz2
gentoo-2-4d12f60993f84329e28ca7e083a76fb459684cf2.zip
Bump to 1.2.0
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/epoch/ChangeLog7
-rw-r--r--sys-apps/epoch/epoch-1.2.0.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/sys-apps/epoch/ChangeLog b/sys-apps/epoch/ChangeLog
index e344a9dbc1f5..6257c0eada76 100644
--- a/sys-apps/epoch/ChangeLog
+++ b/sys-apps/epoch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/epoch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/ChangeLog,v 1.9 2014/12/17 13:25:57 alicef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/ChangeLog,v 1.10 2014/12/24 07:15:18 alicef Exp $
+
+*epoch-1.2.0 (24 Dec 2014)
+
+ 24 Dec 2014; Alice Ferrazzi <alicef@gentoo.org> +epoch-1.2.0.ebuild:
+ Bump to 1.2.0
17 Dec 2014; Alice Ferrazzi <alicef@gentoo.org> metadata.xml:
add myself to maintainers
diff --git a/sys-apps/epoch/epoch-1.2.0.ebuild b/sys-apps/epoch/epoch-1.2.0.ebuild
new file mode 100644
index 000000000000..b10a49d4a103
--- /dev/null
+++ b/sys-apps/epoch/epoch-1.2.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/epoch-1.2.0.ebuild,v 1.1 2014/12/24 07:15:18 alicef Exp $
+
+EAPI="5"
+
+inherit eutils linux-info
+
+MY_PV="${PV/rc/RC}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity"
+HOMEPAGE="http://universe2.us/epoch.html"
+SRC_URI="https://github.com/Subsentient/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~PROC_FS"
+
+ [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
+}
+
+src_compile() {
+ NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
+}
+
+newepochins() {
+ local type="$1"
+
+ cd ${type} || die "Cannot change directory."
+ for file in * ; do
+ if [[ "${file}" != "epoch" ]] ; then
+ new${type} ${file} epoch-${file}
+ fi
+ done
+ cd .. || die "Cannot change directory."
+}
+
+src_install() {
+ cd built || die "Cannot change directory."
+
+ dosbin sbin/epoch
+
+ # For now, rename to epoch-* until we can blend in with a standard approach.
+ newepochins bin
+ newepochins sbin
+
+ insinto /etc/epoch/
+ newins "${FILESDIR}"/${PN}-1.0_rc1-epoch.conf epoch.conf
+}
+
+pkg_postinst() {
+ elog "Make sure to provide /run and /tmp tmpfs mounts using /etc/fstab."
+ elog ""
+ elog "An example epoch configuration is provided at /etc/epoch/epoch.conf"
+ elog "which starts a minimal needed to use Gentoo."
+ elog ""
+ elog "To use epoch, add this kernel parameter: init=/usr/sbin/epoch-init"
+ elog ""
+ elog "Additional information about epoch is available at"
+ elog "${HOMEPAGE} and configuration documentation at"
+ elog "http://universe2.us/epochconfig.html which is useful reading material."
+ elog ""
+ elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
+}