summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-27 10:54:35 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-27 10:54:35 +0000
commit49ac7522b80b5b87e97e8720c224c264de0c157b (patch)
tree05ec45344b3cc0554c6a8f6a48fe6b6c10e42566 /sys-apps
parentStable on Alpha; bug #164011 (diff)
downloadgentoo-2-49ac7522b80b5b87e97e8720c224c264de0c157b.tar.gz
gentoo-2-49ac7522b80b5b87e97e8720c224c264de0c157b.tar.bz2
gentoo-2-49ac7522b80b5b87e97e8720c224c264de0c157b.zip
rip out -Wl,--gc-sections since we use static binaries
(Portage version: 2.1.2-r4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/busybox-1.4.1-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/sys-apps/busybox/busybox-1.4.1-r1.ebuild b/sys-apps/busybox/busybox-1.4.1-r1.ebuild
index 236a99ec71b3..9e7538eaab3e 100644
--- a/sys-apps/busybox/busybox-1.4.1-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.4.1-r1.ebuild,v 1.1 2007/01/27 00:39:16 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.4.1-r1.ebuild,v 1.2 2007/01/27 10:54:35 vapier Exp $
inherit eutils flag-o-matic
@@ -114,6 +114,7 @@ src_unpack() {
-e 's:-Os -falign-functions=1 -falign-jumps=1 -falign-loops=1::' \
-e 's:-fomit-frame-pointer::' \
Makefile.flags
+ sed -i 's:-Wl,--gc-sections::' Makefile
sed -i "/^CFLAGS.*:=/s:$: ${CFLAGS}:" Makefile
echo "CROSS_COMPILE := ${CHOST}-" >> Makefile.flags