summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-06 18:13:11 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-06 18:13:11 +0000
commit48b38a04d1db956c023830aa1ca20ad5782ad94d (patch)
tree1c19ed7787ee89d0b488cec45d5edc7218f82a7d /sys-apps
parentStable on sparc wrt #169640 (diff)
downloadgentoo-2-48b38a04d1db956c023830aa1ca20ad5782ad94d.tar.gz
gentoo-2-48b38a04d1db956c023830aa1ca20ad5782ad94d.tar.bz2
gentoo-2-48b38a04d1db956c023830aa1ca20ad5782ad94d.zip
Add ebuild for git tree.
(Portage version: 2.1.2-r14)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kexec-tools/ChangeLog8
-rw-r--r--sys-apps/kexec-tools/files/digest-kexec-tools-99990
-rw-r--r--sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch14
-rw-r--r--sys-apps/kexec-tools/kexec-tools-9999.ebuild39
4 files changed, 60 insertions, 1 deletions
diff --git a/sys-apps/kexec-tools/ChangeLog b/sys-apps/kexec-tools/ChangeLog
index 18be87bbd51c..e5393cd5df6c 100644
--- a/sys-apps/kexec-tools/ChangeLog
+++ b/sys-apps/kexec-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/kexec-tools
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/ChangeLog,v 1.13 2007/03/06 18:03:52 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/ChangeLog,v 1.14 2007/03/06 18:13:11 vapier Exp $
+
+*kexec-tools-9999 (06 Mar 2007)
+
+ 06 Mar 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/kexec-tools-9999-LDFLAGS.patch, +kexec-tools-9999.ebuild:
+ Add ebuild for git tree.
06 Mar 2007; <genstef@gentoo.org> +files/kexec-linux-headers.patch,
-kexec-tools-1.101.ebuild, kexec-tools-1.101-r3.ebuild:
diff --git a/sys-apps/kexec-tools/files/digest-kexec-tools-9999 b/sys-apps/kexec-tools/files/digest-kexec-tools-9999
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-apps/kexec-tools/files/digest-kexec-tools-9999
diff --git a/sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch b/sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch
new file mode 100644
index 000000000000..c982a3579509
--- /dev/null
+++ b/sys-apps/kexec-tools/files/kexec-tools-9999-LDFLAGS.patch
@@ -0,0 +1,14 @@
+this should really be rewritten to invoke the compiler driver (gcc) rather than
+the linker (ld) ...
+
+--- purgatory/Makefile
++++ purgatory/Makefile
+@@ -59,7 +59,7 @@
+
+ $(PURGATORY): $(PURGATORY_OBJS) $(UTIL_LIB)
+ $(MKDIR) -p $(@D)
+- $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
++ $(LD) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
+
+ echo::
+ @echo "PURGATORY_C_SRCS $(PURGATORY_C_SRCS)"
diff --git a/sys-apps/kexec-tools/kexec-tools-9999.ebuild b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
new file mode 100644
index 000000000000..ebb2f4f39126
--- /dev/null
+++ b/sys-apps/kexec-tools/kexec-tools-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kexec-tools/kexec-tools-9999.ebuild,v 1.1 2007/03/06 18:13:11 vapier Exp $
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/horms/kexec-tools-testing.git"
+inherit git autotools
+
+DESCRIPTION="Load another kernel from the currently executing Linux kernel"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/horms/kexec-tools/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ git_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-LDFLAGS.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_with zlib) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ doman kexec/kexec.8
+ dodoc News AUTHORS TODO doc/*.txt
+
+ newinitd "${FILESDIR}"/kexec.init kexec
+ newconfd "${FILESDIR}"/kexec.conf kexec
+}