summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-01-24 21:32:52 +0000
committerMike Frysinger <vapier@gentoo.org>2003-01-24 21:32:52 +0000
commit48927bc2abf894882427ae27fed581d829355669 (patch)
tree180e366f52b1582f308353e91daa4d9ea3c23d12 /sys-apps
parentdep fix (diff)
downloadgentoo-2-48927bc2abf894882427ae27fed581d829355669.tar.gz
gentoo-2-48927bc2abf894882427ae27fed581d829355669.tar.bz2
gentoo-2-48927bc2abf894882427ae27fed581d829355669.zip
touchups
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sed/sed-4.0.1.ebuild18
-rw-r--r--sys-apps/sed/sed-4.0.5.ebuild18
2 files changed, 14 insertions, 22 deletions
diff --git a/sys-apps/sed/sed-4.0.1.ebuild b/sys-apps/sed/sed-4.0.1.ebuild
index 13ea004ec474..807649030e84 100644
--- a/sys-apps/sed/sed-4.0.1.ebuild
+++ b/sys-apps/sed/sed-4.0.1.ebuild
@@ -1,27 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.1.ebuild,v 1.6 2003/01/18 19:19:26 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.1.ebuild,v 1.7 2003/01/24 21:32:52 vapier Exp $
-IUSE="nls static build"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Super-useful stream editor"
SRC_URI="ftp://ftp.gnu.org/pub/gnu/sed/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/sed/sed.html"
+
KEYWORDS="x86 -ppc sparc alpha mips"
SLOT="0"
LICENSE="GPL-2"
+IUSE="nls static build"
-DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
-
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
src_compile() {
- local myconf
- [ -z "`use nls`" ] && myconf="--disable-nls"
- econf ${myconf} || die
- if [ -z "`use static`" ]
- then
+ econf `use_enable nls` || die
+ if [ `use static` ] ; then
emake || die
else
emake LDFLAGS=-static || die
diff --git a/sys-apps/sed/sed-4.0.5.ebuild b/sys-apps/sed/sed-4.0.5.ebuild
index 5edc5043c01c..c46fb6618db1 100644
--- a/sys-apps/sed/sed-4.0.5.ebuild
+++ b/sys-apps/sed/sed-4.0.5.ebuild
@@ -1,27 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.5.ebuild,v 1.2 2002/12/22 19:20:36 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.5.ebuild,v 1.3 2003/01/24 21:32:52 vapier Exp $
-IUSE="nls static build"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Super-useful stream editor"
SRC_URI="ftp://ftp.gnu.org/pub/gnu/sed/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/sed/sed.html"
+
KEYWORDS="x86 -ppc sparc alpha"
SLOT="0"
LICENSE="GPL-2"
+IUSE="nls static build"
-DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
-
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
src_compile() {
- local myconf
- [ -z "`use nls`" ] && myconf="--disable-nls"
- econf ${myconf} || die
- if [ -z "`use static`" ]
- then
+ econf `use_enable nls` || die
+ if [ `use static` ] ; then
emake || die
else
emake LDFLAGS=-static || die