summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-07-14 00:00:50 +0000
committerMike Gilbert <floppym@gentoo.org>2013-07-14 00:00:50 +0000
commit45cb810a519bf673e46904d9881950a51886941d (patch)
tree727d5ae20c799192e479e3ff5f805f0062652dad /sys-apps
parentFix help text (thanks Thomas J. Moore, bug 476724), update live build. (diff)
downloadgentoo-2-45cb810a519bf673e46904d9881950a51886941d.tar.gz
gentoo-2-45cb810a519bf673e46904d9881950a51886941d.tar.bz2
gentoo-2-45cb810a519bf673e46904d9881950a51886941d.zip
Set file capabilities on systemd-detect-virt, bug 468876 by Michał Bartoszkiewicz.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog7
-rw-r--r--sys-apps/systemd/systemd-205.ebuild7
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild7
3 files changed, 16 insertions, 5 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 7bfda86b81b8..a825b0caf7a9 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.142 2013/07/05 13:52:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.143 2013/07/14 00:00:50 floppym Exp $
+
+ 14 Jul 2013; Mike Gilbert <floppym@gentoo.org> systemd-205.ebuild,
+ systemd-9999.ebuild:
+ Set file capabilities on systemd-detect-virt, bug 468876 by Michał
+ Bartoszkiewicz.
*systemd-205 (05 Jul 2013)
diff --git a/sys-apps/systemd/systemd-205.ebuild b/sys-apps/systemd/systemd-205.ebuild
index b0c011185bfd..59312bd7a464 100644
--- a/sys-apps/systemd/systemd-205.ebuild
+++ b/sys-apps/systemd/systemd-205.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-205.ebuild,v 1.1 2013/07/05 13:52:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-205.ebuild,v 1.2 2013/07/14 00:00:50 floppym Exp $
EAPI=5
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
PYTHON_COMPAT=( python2_7 )
-inherit autotools-utils linux-info multilib pam python-single-r1 systemd toolchain-funcs udev user
+inherit autotools-utils fcaps linux-info multilib pam python-single-r1 systemd toolchain-funcs udev user
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -266,6 +266,9 @@ pkg_postinst() {
udevadm hwdb --update --root="${ROOT%/}"
fi
+ # Bug 468876
+ fcaps cap_dac_override,cap_sys_ptrace=ep usr/bin/systemd-detect-virt
+
if [[ ! -L "${ROOT}"/etc/mtab ]]; then
ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 223822ff206b..18c37b364ebb 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.62 2013/07/05 13:52:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild,v 1.63 2013/07/14 00:00:50 floppym Exp $
EAPI=5
@@ -14,7 +14,7 @@ inherit git-2
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
PYTHON_COMPAT=( python2_7 )
-inherit autotools-utils linux-info multilib pam python-single-r1 systemd toolchain-funcs udev user
+inherit autotools-utils fcaps linux-info multilib pam python-single-r1 systemd toolchain-funcs udev user
DESCRIPTION="System and service manager for Linux"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
@@ -290,6 +290,9 @@ pkg_postinst() {
udevadm hwdb --update --root="${ROOT%/}"
fi
+ # Bug 468876
+ fcaps cap_dac_override,cap_sys_ptrace=ep usr/bin/systemd-detect-virt
+
if [[ ! -L "${ROOT}"/etc/mtab ]]; then
ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
ewarn "It is known to cause users being unable to unmount user mounts. If you don't"