summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2011-02-26 00:34:44 +0000
committerMichael Januszewski <spock@gentoo.org>2011-02-26 00:34:44 +0000
commit457c0809f665548713f6115d90ac89487aa53ed8 (patch)
tree92be6e0215cc9a8c35656231b4e2c9e134cc5428 /sys-apps
parentsparc stable (bug 327053) (diff)
downloadgentoo-2-457c0809f665548713f6115d90ac89487aa53ed8.tar.gz
gentoo-2-457c0809f665548713f6115d90ac89487aa53ed8.tar.bz2
gentoo-2-457c0809f665548713f6115d90ac89487aa53ed8.zip
Version bump.
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/v86d/ChangeLog9
-rw-r--r--sys-apps/v86d/v86d-0.1.10.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/sys-apps/v86d/ChangeLog b/sys-apps/v86d/ChangeLog
index 49e91ae56df1..489b9ec600e1 100644
--- a/sys-apps/v86d/ChangeLog
+++ b/sys-apps/v86d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/v86d
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.31 2010/11/28 18:27:20 spock Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.32 2011/02/26 00:34:44 spock Exp $
+
+*v86d-0.1.10 (26 Feb 2011)
+
+ 26 Feb 2011; Michał Januszewski <spock@gentoo.org> +v86d-0.1.10.ebuild:
+ Version bump.
28 Nov 2010; Michał Januszewski <spock@gentoo.org> v86d-0.1.9.ebuild:
Disable stack protector (bug #346397).
diff --git a/sys-apps/v86d/v86d-0.1.10.ebuild b/sys-apps/v86d/v86d-0.1.10.ebuild
new file mode 100644
index 000000000000..8f921caed33b
--- /dev/null
+++ b/sys-apps/v86d/v86d-0.1.10.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.10.ebuild,v 1.1 2011/02/26 00:34:44 spock Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic linux-info multilib
+
+DESCRIPTION="A daemon to run x86 code in an emulated environment."
+HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
+SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug x86emu"
+
+DEPEND="dev-libs/klibc"
+RDEPEND=""
+
+S="${WORKDIR}/${P//_*/}"
+
+pkg_setup() {
+ if [ -z "$(grep V86D /usr/$(get_libdir)/klibc/include/linux/connector.h)" ]; then
+ eerror "You need to compile klibc against a kernel tree patched with uvesafb"
+ eerror "prior to merging this package."
+ die "Kernel not patched with uvesafb."
+ fi
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ ./configure --with-klibc $(use_with debug) $(use_with x86emu) || die
+}
+
+src_compile() {
+ # Disable stack protector, as it does not work with klibc (bug #346397).
+ filter-flags -fstack-protector -fstack-protector-all
+ emake KDIR="${KV_DIR}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins misc/initramfs
+}
+
+pkg_postinst() {
+ elog "If you wish to place v86d into an initramfs image, you might want to use"
+ elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
+}