summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-29 16:48:24 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-29 16:48:24 +0000
commit454da9251d7fa8aab00867f01b69a97f167e89b8 (patch)
treec00b123955f8dfba69edee7d8c54abdff40f4e5b /sys-apps
parentMarking tclgpgme-1.0-r3 ppc64 for bug 202192 (diff)
downloadgentoo-2-454da9251d7fa8aab00867f01b69a97f167e89b8.tar.gz
gentoo-2-454da9251d7fa8aab00867f01b69a97f167e89b8.tar.bz2
gentoo-2-454da9251d7fa8aab00867f01b69a97f167e89b8.zip
Version bump.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pciutils/ChangeLog7
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.2.93
-rw-r--r--sys-apps/pciutils/pciutils-2.2.9.ebuild49
3 files changed, 58 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 62fb6b642d3c..e70ab3ffc23d 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.123 2007/12/07 22:04:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.124 2007/12/29 16:48:24 vapier Exp $
+
+*pciutils-2.2.9 (29 Dec 2007)
+
+ 29 Dec 2007; Mike Frysinger <vapier@gentoo.org> +pciutils-2.2.9.ebuild:
+ Version bump.
07 Dec 2007; Raúl Porcel <armin76@gentoo.org> pciutils-2.2.8.ebuild:
alpha/ia64/sparc/x86 stable
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.2.9 b/sys-apps/pciutils/files/digest-pciutils-2.2.9
new file mode 100644
index 000000000000..c7bcfde1a605
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.2.9
@@ -0,0 +1,3 @@
+MD5 b3700c60b8b341b593d3c3f274caefb3 pciutils-2.2.9.tar.gz 234382
+RMD160 d46f47e4e70fa52367a80bfab7502c181a753e47 pciutils-2.2.9.tar.gz 234382
+SHA256 7bed38ac8a7db5ce5908e15e6e478cbebeb383694c16a44ac73f88a327b1cb8e pciutils-2.2.9.tar.gz 234382
diff --git a/sys-apps/pciutils/pciutils-2.2.9.ebuild b/sys-apps/pciutils/pciutils-2.2.9.ebuild
new file mode 100644
index 000000000000..08514b8df2a2
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.9.ebuild,v 1.1 2007/12/29 16:48:24 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.7-build.patch
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.6.patch
+ epatch "${FILESDIR}"/${PN}-2.2.4-update-pciids.patch
+ epatch "${FILESDIR}"/${PN}-2.2.7-update-pciids-both-forms.patch
+ sed -i "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+src_compile() {
+ export ZLIB=$(use zlib && echo yes || echo no)
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install install-lib DESTDIR="${D}" || die
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids \
+ || die "Failed to install update cronjob"
+ fi
+
+ # Install both forms until HAL has migrated
+ if use zlib ; then
+ local sharedir="${D}/usr/share/misc"
+ elog "Providing a backwards compatability non-compressed pci.ids"
+ gzip -d <"${sharedir}"/pci.ids.gz >"${sharedir}"/pci.ids
+ fi
+}