summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-03-06 21:59:25 +0000
committerMarinus Schraal <foser@gentoo.org>2005-03-06 21:59:25 +0000
commit3cffcbc56117e34b3f7591873df66654089a4a51 (patch)
treedcb693e9facb325a684973a3df9c17c1f44a37cd /sys-apps
parentmake desktop entry (diff)
downloadgentoo-2-3cffcbc56117e34b3f7591873df66654089a4a51.tar.gz
gentoo-2-3cffcbc56117e34b3f7591873df66654089a4a51.tar.bz2
gentoo-2-3cffcbc56117e34b3f7591873df66654089a4a51.zip
bump fix
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/dbus/ChangeLog8
-rw-r--r--sys-apps/dbus/Manifest7
-rw-r--r--sys-apps/dbus/dbus-0.23.2-r1.ebuild147
-rw-r--r--sys-apps/dbus/dbus-0.23.2.ebuild4
-rw-r--r--sys-apps/dbus/files/30-dbus9
-rw-r--r--sys-apps/dbus/files/dbus-0.23.2-abi_api.patch39
-rw-r--r--sys-apps/dbus/files/dbus-0.23.2-python_api.patch12
-rw-r--r--sys-apps/dbus/files/digest-dbus-0.23.2-r11
8 files changed, 223 insertions, 4 deletions
diff --git a/sys-apps/dbus/ChangeLog b/sys-apps/dbus/ChangeLog
index 2cffbe804b5c..a37215a66b08 100644
--- a/sys-apps/dbus/ChangeLog
+++ b/sys-apps/dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/dbus
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.38 2005/03/02 23:49:25 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.39 2005/03/06 21:59:25 foser Exp $
+
+*dbus-0.23.2-r1 (06 Mar 2005)
+
+ 06 Mar 2005; foser <foser@gentoo.org> dbus-0.23.2-r1.ebuild :
+ Add patch to fix abi/api issues (#83979)
+ Add session launch script (#77504)
*dbus-0.23.2 (03 Mar 2005)
diff --git a/sys-apps/dbus/Manifest b/sys-apps/dbus/Manifest
index 95a9cbbd28ab..a940431345cc 100644
--- a/sys-apps/dbus/Manifest
+++ b/sys-apps/dbus/Manifest
@@ -1,12 +1,17 @@
-MD5 753c054bb8e4d81ce61b97ea62197198 dbus-0.23.2.ebuild 3243
+MD5 659fe09b30edd16a357aea98dde49aeb dbus-0.23.2.ebuild 3244
MD5 7347c59279650f33f950916950ed5fc7 dbus-0.23-r3.ebuild 3242
+MD5 88c904d28401874a8438724b029ad0a5 dbus-0.23.2-r1.ebuild 3453
MD5 ad06b51705dd659e9a5000c04e6c0f90 ChangeLog 5340
MD5 5b5bcd9c1a432b2c8157b0004a073f72 metadata.xml 224
+MD5 9308d3d8014ebf53a946c6219675ffc3 files/dbus-0.23.2-abi_api.patch 1893
MD5 5ad50ae94f784548fc0d6f1364ce23bb files/dbus 544
MD5 db2189cd44431086b05de29565090861 files/dbus-0.23-qt.patch 816
+MD5 46d4825dd8ef38de7c63e0c27f78f46b files/30-dbus 161
MD5 dd13fcb75ab8edf4c308de6a66f2b3e3 files/digest-dbus-0.23.2 64
MD5 403b7724a698be1509916991e87224a4 files/dbus-0.23-pyexecdir.patch 1131
MD5 768e500cfda89809161576ea2080a7aa files/dbus-0.23-dbus_session_connect.patch 1185
MD5 b683f990bc7207366b4dac487a8d1416 files/digest-dbus-0.23-r3 62
MD5 038de28fe446b2303c072e96df531500 files/dbus-0.23.2-version_fix.patch 496
+MD5 c66dfd4b07508de75f541b24035b74af files/dbus-0.23.2-python_api.patch 571
+MD5 dd13fcb75ab8edf4c308de6a66f2b3e3 files/digest-dbus-0.23.2-r1 64
MD5 f3ab25d85c77b7f859d4d2cefc787aef files/dbus-0.23-fd_set.patch 293
diff --git a/sys-apps/dbus/dbus-0.23.2-r1.ebuild b/sys-apps/dbus/dbus-0.23.2-r1.ebuild
new file mode 100644
index 000000000000..713ffb0123b1
--- /dev/null
+++ b/sys-apps/dbus/dbus-0.23.2-r1.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.23.2-r1.ebuild,v 1.1 2005/03/06 21:59:25 foser Exp $
+
+# because of the experimental nature debug by default
+inherit debug eutils mono python multilib
+
+# FIXME : fix docs
+#IUSE="X gtk qt python mono doc xml2"
+IUSE="X gtk qt python mono xml2"
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to eachother"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~x86 ~ppc ~amd64 ~ppc64 ~ia64 ~sparc"
+
+RDEPEND=">=dev-libs/glib-2
+ xml2? ( >=dev-libs/libxml2-2.6 )
+ !xml2? ( dev-libs/expat )
+ X? ( virtual/x11 )
+ gtk? ( >=x11-libs/gtk+-2 )
+ python? ( >=dev-lang/python-2.2
+ >=dev-python/pyrex-0.9 )
+ qt? ( >=x11-libs/qt-3 )
+ !ppc64? (
+ mono? ( >=dev-dotnet/mono-0.95 )
+ )"
+
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+# doc? ( app-doc/doxygen
+# app-text/xmlto )"
+
+# needs gcj, we have no neat way of knowing if it was enabled
+# java? ( sys-devel/gcc )
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.23-qt.patch
+ # add missing include (#78617)
+ epatch ${FILESDIR}/${PN}-0.23-fd_set.patch
+ # workaround mono lib versioning (#81794)
+ epatch ${FILESDIR}/${P}-version_fix.patch
+ # fix python abi/api (#83979)
+ epatch ${FILESDIR}/${P}-abi_api.patch
+ epatch ${FILESDIR}/${P}-python_api.patch
+
+ # It stupidly tries to install python stuff to platform-independent
+ # libdir
+ epatch ${FILESDIR}/dbus-0.23-pyexecdir.patch
+
+ # Don't rerun auto*
+ sleep 1
+ touch ${S}/python/Makefile.in
+ sleep 1
+ touch ${S}/configure
+
+}
+
+src_compile() {
+
+ local myconf
+
+ if use xml2; then
+ myconf="--with-xml=libxml";
+ else
+ myconf="--with-xml=expat";
+ fi
+
+ econf \
+ `use_with X x` \
+ `use_enable gtk` \
+ `use_enable qt` \
+ `use_enable python` \
+ `use_enable mono` \
+ --enable-glib \
+ --enable-verbose-mode \
+ --enable-checks \
+ --enable-asserts \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --with-system-socket=/var/lib/dbus/system_bus_socket \
+ --with-session-socket-dir=/tmp \
+ --disable-doxygen-docs \
+ --disable-xml-docs \
+ --disable-mono-docs \
+ ${myconf} \
+ || die
+
+# `use_enable doc doxygen-docs` \
+# `use_enable doc xml-docs` \
+
+ # do not build the mono examples, they need gtk-sharp
+ touch ${S}/mono/example/{bus-listener,echo-{server,client}}.exe
+
+ # this gets around a lib64 sandbox bug. note that this addpredict is
+ # added automatically by sandbox.c for lib.
+ addpredict /usr/lib64/python2.3/
+ addpredict /usr/lib64/python2.2/
+ addpredict /usr/lib64/python2.1/
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ # initscript
+ exeinto /etc/init.d/
+ doexe ${FILESDIR}/dbus
+
+ # dbus X session script (#77504)
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe ${FILESDIR}/30-dbus
+
+ # needs to exist for the system socket
+ keepdir /var/lib/dbus
+
+ keepdir /usr/lib/dbus-1.0/services
+ keepdir /usr/share/dbus-1/services
+
+ dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO doc/*html
+
+}
+
+pkg_preinst() {
+
+ enewgroup messagebus || die "Problem adding messagebus group"
+ enewuser messagebus -1 /bin/false /dev/null messagebus || die "Problem adding messagebus user"
+
+}
+
+pkg_postinst() {
+
+ einfo "To start the DBUS system-wide messagebus by default"
+ einfo "you should add it to the default runlevel :"
+ einfo "\`rc-update add dbus default\`"
+
+}
diff --git a/sys-apps/dbus/dbus-0.23.2.ebuild b/sys-apps/dbus/dbus-0.23.2.ebuild
index d792aeb9bb11..3d6954c61e4c 100644
--- a/sys-apps/dbus/dbus-0.23.2.ebuild
+++ b/sys-apps/dbus/dbus-0.23.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.23.2.ebuild,v 1.1 2005/03/02 23:49:25 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.23.2.ebuild,v 1.2 2005/03/06 21:59:25 foser Exp $
# because of the experimental nature debug by default
inherit debug eutils mono python multilib
@@ -51,7 +51,7 @@ src_unpack() {
# It stupidly tries to install python stuff to platform-independent
# libdir
- epatch ${FILESDIR}/dbus-0.23-pyexecdir.patch
+# epatch ${FILESDIR}/dbus-0.23-pyexecdir.patch
# Don't rerun auto*
sleep 1
diff --git a/sys-apps/dbus/files/30-dbus b/sys-apps/dbus/files/30-dbus
new file mode 100644
index 000000000000..603e92d3e620
--- /dev/null
+++ b/sys-apps/dbus/files/30-dbus
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+# launches a session dbus instance
+
+dbuslaunch="`which dbus-launch 2>/dev/null`"
+if [ -n "$dbuslaunch" ] && [ -x "$dbuslaunch" ] && [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
+ eval `$dbuslaunch --sh-syntax --exit-with-session`
+fi
+
diff --git a/sys-apps/dbus/files/dbus-0.23.2-abi_api.patch b/sys-apps/dbus/files/dbus-0.23.2-abi_api.patch
new file mode 100644
index 000000000000..d65cbe6afa14
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.23.2-abi_api.patch
@@ -0,0 +1,39 @@
+diff -Naur dbus-0.23.2.orig/dbus/dbus-pending-call.c dbus-0.23.2/dbus/dbus-pending-call.c
+--- dbus-0.23.2.orig/dbus/dbus-pending-call.c 2005-02-28 13:43:54.850066742 +0100
++++ dbus-0.23.2/dbus/dbus-pending-call.c 2005-02-28 13:44:50.266318842 +0100
+@@ -291,6 +291,24 @@
+ }
+
+ /**
++ * Gets the reply, or returns #NULL if none has been received yet. The
++ * reference count is not incremented on the returned message, so you
++ * have to keep a reference count on the pending call (or add one
++ * to the message).
++ *
++ * @todo not thread safe? I guess it has to lock though it sucks
++ * @todo maybe to make this threadsafe, it should be steal_reply(), i.e. only one thread can ever get the message
++ *
++ * @param pending the pending call
++ * @returns the reply message or #NULL.
++ */
++DBusMessage*
++dbus_pending_call_get_reply (DBusPendingCall *pending)
++{
++ return pending->reply;
++}
++
++/**
+ * Block until the pending call is completed. The blocking is as with
+ * dbus_connection_send_with_reply_and_block(); it does not enter the
+ * main loop or process other messages, it simply waits for the reply
+diff -Naur dbus-0.23.2.orig/dbus/dbus-pending-call.h dbus-0.23.2/dbus/dbus-pending-call.h
+--- dbus-0.23.2.orig/dbus/dbus-pending-call.h 2005-02-28 13:43:54.824066155 +0100
++++ dbus-0.23.2/dbus/dbus-pending-call.h 2005-02-28 13:45:30.271222777 +0100
+@@ -42,6 +42,7 @@
+ void dbus_pending_call_cancel (DBusPendingCall *pending);
+ dbus_bool_t dbus_pending_call_get_completed (DBusPendingCall *pending);
+ DBusMessage* dbus_pending_call_steal_reply (DBusPendingCall *pending);
++DBusMessage* dbus_pending_call_get_reply (DBusPendingCall *pending);
+ void dbus_pending_call_block (DBusPendingCall *pending);
+
+ dbus_bool_t dbus_pending_call_allocate_data_slot (dbus_int32_t *slot_p);
diff --git a/sys-apps/dbus/files/dbus-0.23.2-python_api.patch b/sys-apps/dbus/files/dbus-0.23.2-python_api.patch
new file mode 100644
index 000000000000..57ded468fe3e
--- /dev/null
+++ b/sys-apps/dbus/files/dbus-0.23.2-python_api.patch
@@ -0,0 +1,12 @@
+diff -ru dbus-0.23.2.orig/python/dbus_bindings.pyx.in dbus-0.23.2/python/dbus_bindings.pyx.in
+--- dbus-0.23.2.orig/python/dbus_bindings.pyx.in 2005-02-24 11:16:05.771568616 +0100
++++ dbus-0.23.2/python/dbus_bindings.pyx.in 2005-02-24 11:16:38.016303835 +0100
+@@ -395,7 +395,7 @@
+ def get_reply(self):
+ cdef Message message
+ message = Message(_create=0)
+- message._set_msg(dbus_pending_call_get_reply(self.pending_call))
++ message._set_msg(dbus_pending_call_steal_reply(self.pending_call))
+ return message
+
+ def block(self):
diff --git a/sys-apps/dbus/files/digest-dbus-0.23.2-r1 b/sys-apps/dbus/files/digest-dbus-0.23.2-r1
new file mode 100644
index 000000000000..8f47cf24de43
--- /dev/null
+++ b/sys-apps/dbus/files/digest-dbus-0.23.2-r1
@@ -0,0 +1 @@
+MD5 654a2207203636dca0007de384cf0893 dbus-0.23.2.tar.gz 1285494