summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-17 19:51:18 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-17 19:51:18 +0000
commit36503feb0587f07ba47575c84bf2bdb939f0ab40 (patch)
treeb3d1c2d76fb5ab156460c43a579de5723a79928a /sys-apps
parentMask sys-kernel/linuxwacom-module for removal. Bug #347892 (diff)
downloadgentoo-2-36503feb0587f07ba47575c84bf2bdb939f0ab40.tar.gz
gentoo-2-36503feb0587f07ba47575c84bf2bdb939f0ab40.tar.bz2
gentoo-2-36503feb0587f07ba47575c84bf2bdb939f0ab40.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/udevil/ChangeLog8
-rw-r--r--sys-apps/udevil/files/udevil-0.4.1-flags.patch46
-rw-r--r--sys-apps/udevil/udevil-0.4.1.ebuild72
3 files changed, 125 insertions, 1 deletions
diff --git a/sys-apps/udevil/ChangeLog b/sys-apps/udevil/ChangeLog
index 1c5b8bb9643a..c877eda3506c 100644
--- a/sys-apps/udevil/ChangeLog
+++ b/sys-apps/udevil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/udevil
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/udevil/ChangeLog,v 1.25 2013/03/17 16:16:11 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/udevil/ChangeLog,v 1.26 2013/03/17 19:51:18 hasufell Exp $
+
+*udevil-0.4.1 (17 Mar 2013)
+
+ 17 Mar 2013; Julian Ospald <hasufell@gentoo.org> +udevil-0.4.1.ebuild,
+ +files/udevil-0.4.1-flags.patch:
+ version bump
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/sys-apps/udevil/files/udevil-0.4.1-flags.patch b/sys-apps/udevil/files/udevil-0.4.1-flags.patch
new file mode 100644
index 000000000000..166a4357e9f3
--- /dev/null
+++ b/sys-apps/udevil/files/udevil-0.4.1-flags.patch
@@ -0,0 +1,46 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Oct 21 19:33:04 UTC 2012
+Subject: build system
+
+ respect flags where possible
+
+--- configure.ac
++++ configure.ac
+@@ -18,26 +18,6 @@
+
+
+ dnl linker optimizations
+-AC_MSG_CHECKING([whether $LD accepts --as-needed])
+-case `$LD --as-needed -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,--as-needed"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+-AC_MSG_CHECKING([whether $LD accepts -O1])
+-case `$LD -O1 -v 2>&1 </dev/null` in
+-*GNU* | *'with BFD'*)
+- LDFLAGS="$LDFLAGS -Wl,-O1"
+- AC_MSG_RESULT([yes])
+- ;;
+-*)
+- AC_MSG_RESULT([no])
+- ;;
+-esac
+ AC_MSG_CHECKING([whether $LD accepts -Bsymbolic-functions])
+ case `$LD -Bsymbolic-functions -v 2>&1 </dev/null` in
+ *GNU* | *'with BFD'*)
+@@ -49,10 +29,6 @@
+ ;;
+ esac
+
+-dnl advanced compiler tweaking
+-CPPFLAGS="$CPPFLAGS -fstrict-aliasing -fmessage-length=0"
+-
+-
+ # program paths
+ AC_ARG_WITH(mount-prog,
+ AC_HELP_STRING([--with-mount-prog=PATH], [Path to mount program (default: /bin/mount)]),
diff --git a/sys-apps/udevil/udevil-0.4.1.ebuild b/sys-apps/udevil/udevil-0.4.1.ebuild
new file mode 100644
index 000000000000..93e0bb64ffaa
--- /dev/null
+++ b/sys-apps/udevil/udevil-0.4.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/udevil/udevil-0.4.1.ebuild,v 1.1 2013/03/17 19:51:18 hasufell Exp $
+
+EAPI=5
+
+inherit eutils autotools user
+
+DESCRIPTION="mount and unmount removable devices without a password"
+HOMEPAGE="http://ignorantguru.github.com/udevil/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+RDEPEND=">=app-shells/bash-4.0
+ dev-libs/glib:2
+ sys-apps/util-linux
+ virtual/acl
+ >=virtual/udev-143
+ systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup(){
+ enewgroup plugdev
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-flags.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)" \
+ $(use_enable systemd)
+}
+
+src_install() {
+ default
+ fowners root:plugdev /usr/bin/udevil
+ fperms 4754 /usr/bin/udevil
+}
+
+pkg_postinst() {
+ einfo
+ elog "Please add your user to the plugdev group"
+ elog "to be able to use ${PN} as a user"
+ elog
+ elog "Optional dependencies:"
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/davfs2 (mount WebDAV resources)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
+ if ! has_version 'sys-fs/udisks' ; then
+ elog
+ elog "When using ${PN} without udisks, and without the udisks-daemon running,"
+ elog "you may need to enable kernel polling for device media changes to be detected."
+ elog "See http://ignorantguru.github.com/${PN}/#polling"
+ has_version '<virtual/udev-173' && ewarn "You need at least udev-173"
+ kernel_is lt 2 6 38 && ewarn "You need at least kernel 2.6.38"
+ einfo
+ fi
+}