summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 13:06:20 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 13:06:20 +0000
commit35dd377ddfba206efd2c6c6d0d3c3690f82414b7 (patch)
tree59b3780806dc01212c944a9039cf01182d242a2d /sys-apps
parentImport the live ebuild. (diff)
downloadgentoo-2-35dd377ddfba206efd2c6c6d0d3c3690f82414b7.tar.gz
gentoo-2-35dd377ddfba206efd2c6c6d0d3c3690f82414b7.tar.bz2
gentoo-2-35dd377ddfba206efd2c6c6d0d3c3690f82414b7.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd-ui/ChangeLog8
-rw-r--r--sys-apps/systemd-ui/systemd-ui-9999.ebuild63
2 files changed, 69 insertions, 2 deletions
diff --git a/sys-apps/systemd-ui/ChangeLog b/sys-apps/systemd-ui/ChangeLog
index 2344f8946aed..12d87fe0a085 100644
--- a/sys-apps/systemd-ui/ChangeLog
+++ b/sys-apps/systemd-ui/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/systemd-ui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/ChangeLog,v 1.1 2012/03/31 11:52:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/ChangeLog,v 1.2 2012/12/15 13:06:20 mgorny Exp $
+
+*systemd-ui-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +systemd-ui-9999.ebuild:
+ Import the live ebuild.
*systemd-ui-1 (31 Mar 2012)
31 Mar 2012; Michał Górny <mgorny@gentoo.org> +systemd-ui-1.ebuild,
+metadata.xml:
Introduce a separate ebuild for the first release of systemd-ui.
-
diff --git a/sys-apps/systemd-ui/systemd-ui-9999.ebuild b/sys-apps/systemd-ui/systemd-ui-9999.ebuild
new file mode 100644
index 000000000000..a5c65811e676
--- /dev/null
+++ b/sys-apps/systemd-ui/systemd-ui-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd-ui/systemd-ui-9999.ebuild,v 1.1 2012/12/15 13:06:20 mgorny Exp $
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/${PN}
+ http://cgit.freedesktop.org/systemd/${PN}/"
+
+inherit git-2
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="System and service manager for Linux"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
+SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VALASLOT="0.14"
+
+RDEPEND="!sys-apps/systemd[gtk]
+ >=dev-libs/glib-2.26
+ dev-libs/libgee:0.8
+ sys-apps/dbus
+ x11-libs/gtk+:2
+ >=x11-libs/libnotify-0.7"
+
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-lang/vala:${VALASLOT}"
+
+#if LIVE
+SRC_URI=
+KEYWORDS=
+
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.2"
+#endif
+
+# Due to vala being broken.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # Force the rebuild of .vala sources
+ touch src/*.vala || die
+
+ # Fix hardcoded path in .vala.
+ sed -i -e 's:/lib/systemd:/usr/lib/systemd:g' src/*.vala || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ export VALAC="$(type -p valac-${VALASLOT})"
+ autotools-utils_src_configure
+}