summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-05-26 09:33:52 +0000
committerPreston A. Elder <prez@gentoo.org>2002-05-26 09:33:52 +0000
commit2c13ac1c47ac0e23836f9cc0040b16a34581d8b3 (patch)
tree5ee1e8ab75b2299d06964e8e48d1bc0948b1a36b /sys-apps
parentRemoved galeon mask (diff)
downloadgentoo-2-2c13ac1c47ac0e23836f9cc0040b16a34581d8b3.tar.gz
gentoo-2-2c13ac1c47ac0e23836f9cc0040b16a34581d8b3.tar.bz2
gentoo-2-2c13ac1c47ac0e23836f9cc0040b16a34581d8b3.zip
Fixed GCC 3.1 support
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute/iproute-20010824.ebuild5
-rw-r--r--sys-apps/iproute2/ChangeLog6
-rw-r--r--sys-apps/iproute2/iproute2-2.4.7-r1.ebuild5
3 files changed, 11 insertions, 5 deletions
diff --git a/sys-apps/iproute/iproute-20010824.ebuild b/sys-apps/iproute/iproute-20010824.ebuild
index fd1f66a48c07..1bd1fbbdde26 100644
--- a/sys-apps/iproute/iproute-20010824.ebuild
+++ b/sys-apps/iproute/iproute-20010824.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/iproute-20010824.ebuild,v 1.2 2002/04/25 06:56:23 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/iproute-20010824.ebuild,v 1.3 2002/05/26 09:33:52 prez Exp $
S=${WORKDIR}/iproute2
DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
@@ -17,7 +17,8 @@ src_unpack() {
# they seem ok here when i compile with optimisations, so im reenabling
# this patch. if theres problems, will glady change back. ~woodchip
cp Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
+ sed -e "s/-O2/${CFLAGS}/g" \
+ -e "s/-Werror//g" Makefile.orig > Makefile
# this next thing is required to enable diffserv (ATM support doesn't compile right now)
cp Config Config.orig
diff --git a/sys-apps/iproute2/ChangeLog b/sys-apps/iproute2/ChangeLog
index 313a16446b70..b6ef96568373 100644
--- a/sys-apps/iproute2/ChangeLog
+++ b/sys-apps/iproute2/ChangeLog
@@ -1,12 +1,16 @@
# ChangeLog for sys-apps/iproute2
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.2 2002/02/08 05:37:03 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/ChangeLog,v 1.3 2002/05/26 09:33:14 prez Exp $
*iproute2-2.4.7-r1 (7 Feb 2002)
+ 26 May 2002: Preston A. Elder <prez@gentoo.org>: Removed -Werror from the
+ makefile, which allows gcc 3.1 to compile.
+
7 Feb 2002; Daniel Robbins <drobbins@gentoo.org>: Added a dead-route-fix.diff to
close bug #595 (see it for a description of the problem it fixes)
+
*iproute2-2.4.7 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/sys-apps/iproute2/iproute2-2.4.7-r1.ebuild b/sys-apps/iproute2/iproute2-2.4.7-r1.ebuild
index 3e75dc04ea13..e528f5368a46 100644
--- a/sys-apps/iproute2/iproute2-2.4.7-r1.ebuild
+++ b/sys-apps/iproute2/iproute2-2.4.7-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.4.7-r1.ebuild,v 1.1 2002/02/08 05:37:03 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute2/iproute2-2.4.7-r1.ebuild,v 1.2 2002/05/26 09:33:14 prez Exp $
S=${WORKDIR}/iproute2
DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
@@ -33,7 +33,8 @@ src_unpack() {
# they seem ok here when i compile with optimisations, so im reenabling
# this patch. if theres problems, will glady change back. ~woodchip
cp Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/g" Makefile.orig > Makefile
+ sed -e "s/-O2/${CFLAGS}/g" \
+ -e "s/-Werror//g" Makefile.orig > Makefile
# this next thing is required to enable diffserv (ATM support doesn't compile right now)
# cp Config Config.orig