summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-04-02 03:05:02 +0000
committerMike Frysinger <vapier@gentoo.org>2009-04-02 03:05:02 +0000
commit2436abb4c3adf86571c6fd21dbc876ff06cba921 (patch)
tree4fdd6180f1016aaea6815f449a520a1f8124b718 /sys-apps
parentMarked ppc stable for bug #264496. (diff)
downloadgentoo-2-2436abb4c3adf86571c6fd21dbc876ff06cba921.tar.gz
gentoo-2-2436abb4c3adf86571c6fd21dbc876ff06cba921.tar.bz2
gentoo-2-2436abb4c3adf86571c6fd21dbc876ff06cba921.zip
Disable pthread locks to make 1.6 regression free #264476.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/ChangeLog8
-rw-r--r--sys-apps/sandbox/files/sandbox-1.6-disable-pthread.patch37
-rw-r--r--sys-apps/sandbox/sandbox-1.6-r2.ebuild99
3 files changed, 143 insertions, 1 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 69fb1e50a8ce..1fb1ed7bba78 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.111 2009/03/31 11:56:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.112 2009/04/02 03:04:56 vapier Exp $
+
+*sandbox-1.6-r2 (02 Apr 2009)
+
+ 02 Apr 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/sandbox-1.6-disable-pthread.patch, +sandbox-1.6-r2.ebuild:
+ Disable pthread locks to make 1.6 regression free #264476.
*sandbox-1.6-r1 (31 Mar 2009)
diff --git a/sys-apps/sandbox/files/sandbox-1.6-disable-pthread.patch b/sys-apps/sandbox/files/sandbox-1.6-disable-pthread.patch
new file mode 100644
index 000000000000..490bc41c0eed
--- /dev/null
+++ b/sys-apps/sandbox/files/sandbox-1.6-disable-pthread.patch
@@ -0,0 +1,37 @@
+http://bugs.gentoo.org/263657
+
+disable pthread locks ... this is how stable has always worked, so there
+wont be any regressions ...
+
+diff --git a/libsandbox/libsandbox.c b/libsandbox/libsandbox.c
+index 034d0e7..595d17f 100644
+--- a/libsandbox/libsandbox.c
++++ b/libsandbox/libsandbox.c
+@@ -814,9 +814,6 @@
+ return result;
+ }
+
+-/* Need to protect the global sbcontext structure */
+-static pthread_mutex_t sb_syscall_lock = PTHREAD_MUTEX_INITIALIZER;
+-
+ bool before_syscall(int dirfd, int sb_nr, const char *func, const char *file, int flags)
+ {
+ int old_errno = errno;
+@@ -843,8 +840,6 @@
+ file = at_file_buf;
+ }
+
+- pthread_mutex_lock(&sb_syscall_lock);
+-
+ if (!sb_init) {
+ init_context(&sbcontext);
+ sb_init = true;
+@@ -885,8 +880,6 @@
+
+ result = check_syscall(&sbcontext, sb_nr, func, file, flags);
+
+- pthread_mutex_unlock(&sb_syscall_lock);
+-
+ if (0 == result) {
+ if ((NULL != getenv(ENV_SANDBOX_PID)) && (is_env_on(ENV_SANDBOX_ABORT)))
+
diff --git a/sys-apps/sandbox/sandbox-1.6-r2.ebuild b/sys-apps/sandbox/sandbox-1.6-r2.ebuild
new file mode 100644
index 000000000000..426934b089e1
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.6-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.6-r2.ebuild,v 1.1 2009/04/02 03:04:56 vapier Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.lzma
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="app-arch/lzma-utils"
+RDEPEND=""
+
+EMULTILIB_PKG="true"
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES=-sandbox emerge sandbox"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-disable-qa-static.patch
+ epatch "${FILESDIR}"/${P}-disable-pthread.patch
+ epatch "${FILESDIR}"/0001-libsandbox-handle-more-at-functions.patch
+}
+
+src_compile() {
+ filter-lfs-flags #90228
+
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ mkdir "${WORKDIR}/build-${ABI}"
+ cd "${WORKDIR}/build-${ABI}"
+
+ multilib_toolchain_setup ${ABI}
+
+ einfo "Configuring sandbox for ABI=${ABI}..."
+ ECONF_SOURCE="../${P}/" \
+ econf ${myconf} || die
+ einfo "Building sandbox for ABI=${ABI}..."
+ emake || die
+ done
+ ABI=${OABI}
+}
+
+src_test() {
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ cd "${WORKDIR}/build-${ABI}"
+ einfo "Checking sandbox for ABI=${ABI}..."
+ emake check || die "make check failed for ${ABI}"
+ done
+ ABI=${OABI}
+}
+
+src_install() {
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ cd "${WORKDIR}/build-${ABI}"
+ einfo "Installing sandbox for ABI=${ABI}..."
+ emake DESTDIR="${D}" install || die "make install failed for ${ABI}"
+ done
+ ABI=${OABI}
+
+ doenvd "${FILESDIR}"/09sandbox
+
+ keepdir /var/log/sandbox
+ fowners root:portage /var/log/sandbox
+ fperms 0770 /var/log/sandbox
+
+ cd "${S}"
+ dodoc AUTHORS ChangeLog* NEWS README
+}
+
+pkg_preinst() {
+ chown root:portage "${D}"/var/log/sandbox
+ chmod 0770 "${D}"/var/log/sandbox
+
+ local old=$(find "${ROOT}"/lib* -maxdepth 1 -name 'libsandbox*')
+ if [[ -n ${old} ]] ; then
+ elog "Removing old sandbox libraries for you:"
+ elog ${old//${ROOT}}
+ find "${ROOT}"/lib* -maxdepth 1 -name 'libsandbox*' -exec rm -fv {} \;
+ fi
+}