summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Færøy <eroyf@gentoo.org>2007-01-27 23:05:14 +0000
committerAlexander Færøy <eroyf@gentoo.org>2007-01-27 23:05:14 +0000
commit2213596d8bcde5f77876a29fccec23959907e6d4 (patch)
tree3ff479a824680ff0eb929639e12c40d75ea8cb11 /sys-apps
parentAdd warning on installation of debug version (diff)
downloadgentoo-2-2213596d8bcde5f77876a29fccec23959907e6d4.tar.gz
gentoo-2-2213596d8bcde5f77876a29fccec23959907e6d4.tar.bz2
gentoo-2-2213596d8bcde5f77876a29fccec23959907e6d4.zip
Version Bump.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/paludis/ChangeLog8
-rw-r--r--sys-apps/paludis/files/digest-paludis-0.16.23
-rw-r--r--sys-apps/paludis/paludis-0.16.2.ebuild118
3 files changed, 128 insertions, 1 deletions
diff --git a/sys-apps/paludis/ChangeLog b/sys-apps/paludis/ChangeLog
index d362614b1865..71a223d082d5 100644
--- a/sys-apps/paludis/ChangeLog
+++ b/sys-apps/paludis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/paludis
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.42 2007/01/26 21:51:27 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/ChangeLog,v 1.43 2007/01/27 23:05:14 eroyf Exp $
+
+*paludis-0.16.2 (28 Jan 2007)
+
+ 28 Jan 2007; Alexander H. Færøy <eroyf@gentoo.org>
+ +paludis-0.16.2.ebuild:
+ Version Bump.
*paludis-0.16.1 (26 Jan 2007)
diff --git a/sys-apps/paludis/files/digest-paludis-0.16.2 b/sys-apps/paludis/files/digest-paludis-0.16.2
new file mode 100644
index 000000000000..e0c7101aacfa
--- /dev/null
+++ b/sys-apps/paludis/files/digest-paludis-0.16.2
@@ -0,0 +1,3 @@
+MD5 a96c1b317f6b58195dc433ae0e85daf3 paludis-0.16.2.tar.bz2 1314288
+RMD160 5930536b05e2324861f168d3ffc7201c5865082a paludis-0.16.2.tar.bz2 1314288
+SHA256 0bc8d051e593d1269e040b25760940b119d8e843ef6e66234a917c540ff26025 paludis-0.16.2.tar.bz2 1314288
diff --git a/sys-apps/paludis/paludis-0.16.2.ebuild b/sys-apps/paludis/paludis-0.16.2.ebuild
new file mode 100644
index 000000000000..23ccd79b670d
--- /dev/null
+++ b/sys-apps/paludis/paludis-0.16.2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paludis/paludis-0.16.2.ebuild,v 1.1 2007/01/27 23:05:14 eroyf Exp $
+
+inherit bash-completion eutils flag-o-matic
+
+DESCRIPTION="paludis, the other package mangler"
+HOMEPAGE="http://paludis.pioto.org/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="contrarius cran doc glsa pink qa ruby selinux zsh-completion"
+
+COMMON_DEPEND="
+ >=app-shells/bash-3
+ selinux? ( sys-libs/libselinux )
+ qa? ( dev-libs/pcre++ >=dev-libs/libxml2-2.6 app-crypt/gnupg )
+ glsa? ( >=dev-libs/libxml2-2.6 )
+ ruby? ( >=dev-lang/ruby-1.8 )"
+
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/libebt
+ >=dev-cpp/libwrapiter-1.0.0
+ doc? ( app-doc/doxygen media-gfx/imagemagick )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=app-admin/eselect-1.0.2
+ net-misc/wget
+ net-misc/rsync
+ !mips? ( sys-apps/sandbox )"
+
+PROVIDE="virtual/portage"
+
+pkg_setup() {
+ # gcc generates bad code...
+ use amd64 && replace-flags -Os -O2
+
+ if is-ldflagq -Wl,--as-needed || is-ldflagq --as-needed ; then
+ echo
+ ewarn "Stripping as-needed from LDFLAGS."
+ ewarn "You should not set this variable globally. Please read:"
+ ewarn " http://ciaranm.org/show_post.pl?post_id=13"
+ echo
+ epause 10
+ fi
+ filter-ldflags -Wl,--as-needed --as-needed
+}
+
+src_compile() {
+ local repositories=`echo default $(usev cran) | tr -s \ ,`
+ local clients=`echo default $(usev contrarius) | tr -s \ ,`
+ econf \
+ $(use_enable doc doxygen ) \
+ $(use_enable !mips sandbox ) \
+ $(use_enable pink) \
+ $(use_enable selinux) \
+ $(use_enable qa) \
+ $(use_enable ruby) \
+ $(use_enable glsa) \
+ --with-repositories=${repositories} \
+ --with-clients=${clients} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+ if use doc ; then
+ make doxygen || die "make doxygen failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS README ChangeLog NEWS
+
+ BASH_COMPLETION_NAME="adjutrix" dobashcompletion bash-completion/adjutrix
+ BASH_COMPLETION_NAME="paludis" dobashcompletion bash-completion/paludis
+ use qa && \
+ BASH_COMPLETION_NAME="qualudis" dobashcompletion bash-completion/qualudis
+
+ if use doc ; then
+ dohtml -r -V doc/www/*
+ fi
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins zsh-completion/_paludis
+ doins zsh-completion/_adjutrix
+ doins zsh-completion/_paludis_packages
+ fi
+}
+
+src_test() {
+ # Work around Portage bugs
+ export PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
+ export BASH_ENV=/dev/null
+
+ emake check || die "Make check failed"
+}
+
+pkg_postinst() {
+ if use bash-completion ; then
+ echo
+ einfo "The following bash completion scripts have been installed:"
+ einfo " paludis"
+ einfo " adjutrix"
+ use qa && einfo " qualudis"
+ einfo
+ einfo "To enable these scripts, run:"
+ einfo " eselect bashcomp enable <scriptname>"
+ fi
+
+ echo
+ einfo "Before using Paludis and before reporting issues, you should read:"
+ einfo " http://paludis.pioto.org/faq.html"
+ echo
+}
+