summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2002-06-09 06:21:25 +0000
committerMark Guertin <gerk@gentoo.org>2002-06-09 06:21:25 +0000
commit20c43d4d8a4d46c6393251494c48296af4b917f4 (patch)
tree41c410749d116e7fcec03470a512f4a5934c6708 /sys-apps
parentnew port; #2440 (diff)
downloadgentoo-2-20c43d4d8a4d46c6393251494c48296af4b917f4.tar.gz
gentoo-2-20c43d4d8a4d46c6393251494c48296af4b917f4.tar.bz2
gentoo-2-20c43d4d8a4d46c6393251494c48296af4b917f4.zip
Updated for ppc fixes (left new orinoco driver commented as it was still masked
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcmcia-cs/ChangeLog9
-rw-r--r--sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.33-r51
-rw-r--r--sys-apps/pcmcia-cs/files/ppc.config.opts9
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.1.33-r5.ebuild129
4 files changed, 147 insertions, 1 deletions
diff --git a/sys-apps/pcmcia-cs/ChangeLog b/sys-apps/pcmcia-cs/ChangeLog
index d5991f3ffc70..163d850356dc 100644
--- a/sys-apps/pcmcia-cs/ChangeLog
+++ b/sys-apps/pcmcia-cs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/pcmcia-cs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.11 2002/05/01 13:01:29 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/ChangeLog,v 1.12 2002/06/09 06:21:25 gerk Exp $
+
+*pcmcia-cs-3.1.33-r5 (09 June 2002)
+
+ 08 June 2002; Mark Guertin <gerk@gentoo.org>
+
+ Added ppc fixes to this ebuild. Left new orinoco driver section in (but commented as it is still testing)
+
*pcmcia-cs-3.1.33-r4 (01 May 2002)
diff --git a/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.33-r5 b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.33-r5
new file mode 100644
index 000000000000..f489e12747ab
--- /dev/null
+++ b/sys-apps/pcmcia-cs/files/digest-pcmcia-cs-3.1.33-r5
@@ -0,0 +1 @@
+MD5 960901f091408a75cfd4488a52f76dc8 pcmcia-cs-3.1.33.tar.gz 1244416
diff --git a/sys-apps/pcmcia-cs/files/ppc.config.opts b/sys-apps/pcmcia-cs/files/ppc.config.opts
new file mode 100644
index 000000000000..3df34ee7529b
--- /dev/null
+++ b/sys-apps/pcmcia-cs/files/ppc.config.opts
@@ -0,0 +1,9 @@
+#
+# Local PCMCIA Configuration File
+#
+#----------------------------------------------------------------------
+
+include port 0x1000-0x1fff
+include memory 0x90000000-0x9003ffff
+
+# all other modules should be kernel modules on ppc
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.1.33-r5.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.33-r5.ebuild
new file mode 100644
index 000000000000..8631ce265cc1
--- /dev/null
+++ b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.33-r5.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Header: $
+
+# This ebuild installs ${FILESDIR}/hermes.conf, which you can get from
+# http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/hermes.conf
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PCMCIA tools for Linux"
+SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz"
+HOMEPAGE="http://pcmcia-cs.sourceforge.net"
+DEPEND="sys-kernel/linux-headers"
+RDEPEND=""
+SLOT=0
+LICENSE=GPL
+
+# check arch for configure
+if [ ${ARCH} = "x86" ] ; then
+ MY_ARCH="i386"
+else
+ MY_ARCH="ppc"
+fi
+
+# Note: To use this ebuild, you should have the usr/src/linux symlink to
+# the kernel directory that pcmcia-cs should use for configuration.
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ # commented this stuff out as it is still in packages.mask for testing - gerk june 08 2002
+# unpack orinoco-0.11a.tar.gz
+# cd ${S}
+# mv ../orinoco-0.11a/hermes*.{c,h} \
+# ../orinoco-0.11a/orinoco*.{c,h} \
+# ../orinoco-0.11a/ieee802_11.h wireless/
+# cp Configure Configure.orig
+# sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
+# #man pages will now install into /usr/share/man
+}
+
+src_compile() {
+ local myconf
+ if [ -n "`use trusted`" ] ; then
+ myconf="--trust"
+ else
+ myconf="--notrust"
+ fi
+
+ if [ -n "`use apm`" ] ; then
+ myconf="$myconf --apm"
+ else
+ myconf="$myconf --noapm"
+ fi
+
+ if [ -n "`use pnp`" ] ; then
+ myconf="$myconf --pnp"
+ else
+ myconf="$myconf --nopnp"
+ fi
+
+ if [ -n "`use nocardbus`" ] ; then
+ myconf="$myconf --nocardbus"
+ else
+ myconf="$myconf --cardbus"
+ fi
+
+ #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
+ ./Configure -n \
+ --target=${D} \
+ --srctree \
+ --kernel=/usr/src/linux \
+ --arch="${MY_ARCH}" \
+ --uflags="$CFLAGS" \
+ --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
+ $myconf || die "failed configuring"
+ # nopnp and noapm are important, because without them the pcmcia-cs
+ # tools will require a kernel with ISA PnP and/or APM support,
+ # which cannot be guaranteed. We need to make sure the tools
+ # work *all* the time, not just some of the time.
+
+ # The --srctree option tells pcmcia-cs to configure for the kernel in /usr/src/linux
+ # rather than the currently-running kernel. It's Gentoo Linux policy to configure for
+ # the kernel in /usr/src/linux
+ emake all || die "failed compiling"
+}
+
+src_install () {
+ make PREFIX=${D} install || die "failed installing"
+ cd ${D}
+ rm -rf etc/rc*.d
+ # remove X
+ # this is simply much easier than patching configure or the makefiles
+ # not to build them in the first place
+ rm -rf usr/X11R6
+ # todo: if they are nstalled, move them to /usr
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pcmcia.conf pcmcia
+
+ exeinto /etc/pcmcia
+ doexe ${FILESDIR}/network
+
+ # install our own init script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pcmcia.rc6 pcmcia
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ # install docs
+ dodoc BUGS CHANGES COPYING LICENSE MAINTAINERS README \
+ README-2.4 SUPPORTED.CARDS doc/*
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+ rm -f ${D}/etc/modules.conf
+ rm -rf ${D}/var/lib/pcmcia
+
+ # if on ppc set the ppc revised config.opts
+ if [ ${ARCH} = "ppc" ] ; then
+# cp ${FILESDIR}/ppc.config.opt ${D}/etc/pcmcia/config.opt
+ insinto /etc/pcmcia
+ newins ${FILESDIR}/ppc.config.opts config.opts
+ fi
+}
+
+src_postinst() {
+ einfo "To avail yourself of the pcmcia-cs drivers, you have to disable the PCMCIA support in the kernel."
+ einfo "(Otherwise, you might experience CardServices version mismatch errors)"
+}