summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-02-07 13:39:20 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-02-07 13:39:20 +0000
commit16c02a115d09aa82a055aef67116ea3fd76c0727 (patch)
treef571b6d96fcc747542753a306d20b2abaded2df4 /sys-apps
parentVersion BUmp (diff)
downloadgentoo-2-16c02a115d09aa82a055aef67116ea3fd76c0727.tar.gz
gentoo-2-16c02a115d09aa82a055aef67116ea3fd76c0727.tar.bz2
gentoo-2-16c02a115d09aa82a055aef67116ea3fd76c0727.zip
Version bump to 1.0, fixes bug #500462.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/epoch/ChangeLog10
-rw-r--r--sys-apps/epoch/epoch-1.0.ebuild74
-rw-r--r--sys-apps/epoch/epoch-9999.ebuild6
-rw-r--r--sys-apps/epoch/files/epoch-1.0-fix-CFLAGS.patch10
4 files changed, 95 insertions, 5 deletions
diff --git a/sys-apps/epoch/ChangeLog b/sys-apps/epoch/ChangeLog
index 07cd037f5bd2..fbfe7b45d515 100644
--- a/sys-apps/epoch/ChangeLog
+++ b/sys-apps/epoch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/epoch
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/ChangeLog,v 1.3 2013/12/22 12:45:09 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/ChangeLog,v 1.4 2014/02/07 13:39:20 tomwij Exp $
+
+*epoch-1.0 (07 Feb 2014)
+
+ 07 Feb 2014; Tom Wijsman <TomWij@gentoo.org> +epoch-1.0.ebuild,
+ +files/epoch-1.0-fix-CFLAGS.patch, epoch-9999.ebuild:
+ Version bump to 1.0, fixes bug #500462.
*epoch-1.0_rc2 (22 Dec 2013)
diff --git a/sys-apps/epoch/epoch-1.0.ebuild b/sys-apps/epoch/epoch-1.0.ebuild
new file mode 100644
index 000000000000..2af01de0834e
--- /dev/null
+++ b/sys-apps/epoch/epoch-1.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/epoch-1.0.ebuild,v 1.1 2014/02/07 13:39:20 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils linux-info
+
+MY_PV="${PV/rc/RC}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity."
+HOMEPAGE="http://universe2.us/epoch.html"
+SRC_URI="https://github.com/Subsentient/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~PROC_FS"
+
+ [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
+}
+
+src_compile() {
+ NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
+}
+
+newepochins() {
+ local type="$1"
+
+ cd ${type} || die "Cannot change directory."
+ for file in * ; do
+ if [[ "${file}" != "epoch" ]] ; then
+ new${type} ${file} epoch-${file}
+ fi
+ done
+ cd .. || die "Cannot change directory."
+}
+
+src_install() {
+ cd built || die "Cannot change directory."
+
+ dosbin sbin/epoch
+
+ # For now, rename to epoch-* until we can blend in with a standard approach.
+ newepochins bin
+ newepochins sbin
+
+ insinto /etc/epoch/
+ newins "${FILESDIR}"/${PN}-1.0_rc1-epoch.conf epoch.conf
+}
+
+pkg_postinst() {
+ elog "Make sure to provide /run and /tmp tmpfs mounts using /etc/fstab."
+ elog ""
+ elog "An example epoch configuration is provided at /etc/epoch/epoch.conf"
+ elog "which starts a minimal needed to use Gentoo."
+ elog ""
+ elog "To use epoch, add this kernel parameter: init=/usr/sbin/epoch-init"
+ elog ""
+ elog "Additional information about epoch is available at"
+ elog "${HOMEPAGE} and configuration documentation at"
+ elog "http://universe2.us/epochconfig.html which is useful reading material."
+ elog ""
+ elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
+}
diff --git a/sys-apps/epoch/epoch-9999.ebuild b/sys-apps/epoch/epoch-9999.ebuild
index 674d4beefd39..ea110850c030 100644
--- a/sys-apps/epoch/epoch-9999.ebuild
+++ b/sys-apps/epoch/epoch-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/epoch-9999.ebuild,v 1.2 2013/12/07 21:17:40 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/epoch/epoch-9999.ebuild,v 1.3 2014/02/07 13:39:20 tomwij Exp $
EAPI="5"
@@ -26,7 +26,7 @@ pkg_pretend() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0_rc1-fix-CFLAGS.patch
+ epatch "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
}
src_compile() {
diff --git a/sys-apps/epoch/files/epoch-1.0-fix-CFLAGS.patch b/sys-apps/epoch/files/epoch-1.0-fix-CFLAGS.patch
new file mode 100644
index 000000000000..92842722225a
--- /dev/null
+++ b/sys-apps/epoch/files/epoch-1.0-fix-CFLAGS.patch
@@ -0,0 +1,10 @@
+--- a/buildepoch.sh
++++ b/buildepoch.sh
+@@ -53,6 +53,6 @@
+ }
+
+-NEED_EMPTY_CFLAGS="0"
++NEED_EMPTY_CFLAGS="1"
+ outdir="../built"
+
+ if [ "$CC" == "" ]; then