summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-07-17 20:06:49 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-07-17 20:06:49 +0000
commit142406ff29f2e28817ebd42843bb61dc89d03bab (patch)
tree4bac3f5bd2071f4e45c18f5d521c30fe38d6edac /sys-apps
parentBug #232068, version bump. (diff)
downloadgentoo-2-142406ff29f2e28817ebd42843bb61dc89d03bab.tar.gz
gentoo-2-142406ff29f2e28817ebd42843bb61dc89d03bab.tar.bz2
gentoo-2-142406ff29f2e28817ebd42843bb61dc89d03bab.zip
version bump. fix ogg and gzip detection. bugs #219215 & #215499
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-4.25.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 1c6832917cd3..1be317512c11 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.160 2008/03/29 15:23:34 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.161 2008/07/17 20:06:49 cardoe Exp $
+
+*file-4.25 (17 Jul 2008)
+
+ 17 Jul 2008; Doug Goldstein <cardoe@gentoo.org> +file-4.25.ebuild:
+ version bump. fix ogg and gzip detection. bugs #219215 & #215499
29 Mar 2008; Brent Baude <ranger@gentoo.org> file-4.23.ebuild:
stable ppc64, bug 215058
diff --git a/sys-apps/file/file-4.25.ebuild b/sys-apps/file/file-4.25.ebuild
new file mode 100644
index 000000000000..ff07e0b7d895
--- /dev/null
+++ b/sys-apps/file/file-4.25.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.25.ebuild,v 1.1 2008/07/17 20:06:49 cardoe Exp $
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="python"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+
+ elibtoolize
+ epunt_cxx
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}