summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-05 20:11:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-05 20:11:39 +0000
commit12040f827a5669317825a18df43e8bd4894c8745 (patch)
treed7e7b3355bd01073b6201b9829ec2424cf57bf17 /sys-apps
parentFix prerm phase per bug #275918. (diff)
downloadgentoo-2-12040f827a5669317825a18df43e8bd4894c8745.tar.gz
gentoo-2-12040f827a5669317825a18df43e8bd4894c8745.tar.bz2
gentoo-2-12040f827a5669317825a18df43e8bd4894c8745.zip
modprobe.d filename style change for new modprobe.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/x86info/ChangeLog8
-rw-r--r--sys-apps/x86info/x86info-1.24-r2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/sys-apps/x86info/ChangeLog b/sys-apps/x86info/ChangeLog
index 0ce5908d6bbd..32fe21fd953a 100644
--- a/sys-apps/x86info/ChangeLog
+++ b/sys-apps/x86info/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/x86info
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.26 2009/05/14 12:21:43 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/ChangeLog,v 1.27 2009/07/05 20:11:39 robbat2 Exp $
+
+*x86info-1.24-r2 (05 Jul 2009)
+
+ 05 Jul 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +x86info-1.24-r2.ebuild:
+ modprobe.d filename style change for new modprobe.
14 May 2009; Christian Faulhammer <fauli@gentoo.org>
x86info-1.24-r1.ebuild:
diff --git a/sys-apps/x86info/x86info-1.24-r2.ebuild b/sys-apps/x86info/x86info-1.24-r2.ebuild
new file mode 100644
index 000000000000..fa93d61c5fd1
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.24-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.24-r2.ebuild,v 1.1 2009/07/05 20:11:39 robbat2 Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.21-pic.patch
+}
+
+src_compile() {
+ emake x86info CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+pkg_preinst() {
+ if [[ -a /etc/modules.d/x86info ]] && [[ ! -a /etc/modprobe.d/x86info ]]; then
+ elog "Moving old x86info configuration in modules.d to new"
+ elog "location in modprobe.d in /etc/"
+ mv "${ROOT}"/etc/{modules,modprobe}.d/x86info
+ fi
+ if [[ -a /etc/modprobe.d/x86info ]] && [[ ! -a /etc/modprobe.d/x86info.conf ]]; then
+ elog "Moving old x86info configuration in modprobe.d to"
+ elog "new naming scheme with trailing .conf"
+ mv "${ROOT}"/etc/modprobe.d/x86info{,.conf}
+ fi
+}
+
+src_install() {
+ dobin x86info || die
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
+
+ dodoc TODO README
+ doman x86info.1
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}