summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-18 21:23:44 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-18 21:23:44 +0000
commit1098f7fb00a9e5a54d30d3ce9101338934e10b6b (patch)
treec45c816a0566e5a3db2861f51789532ad627a3ec /sys-apps
parentNew package. Closes #2485 (diff)
downloadgentoo-2-1098f7fb00a9e5a54d30d3ce9101338934e10b6b.tar.gz
gentoo-2-1098f7fb00a9e5a54d30d3ce9101338934e10b6b.tar.bz2
gentoo-2-1098f7fb00a9e5a54d30d3ce9101338934e10b6b.zip
revival
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/texinfo/texinfo-4.0-r3.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/texinfo/texinfo-4.0-r3.ebuild b/sys-apps/texinfo/texinfo-4.0-r3.ebuild
new file mode 100644
index 000000000000..181f0f4cf2bc
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.0-r3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Achim Gottinger <achim@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.0-r3.ebuild,v 1.5 2002/05/18 21:23:44 spider Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU info program and utilities"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/texinfo/${A}
+ ftp://ftp.gnu.org/pub/gnu/texinfo/${A}"
+
+if [ "`use build`" ] ; then
+ DEPEND="virtual/glibc"
+else
+ DEPEND="virtual/glibc >=sys-libs/ncurses-5.2-r2 nls? ( sys-devel/gettext )"
+ RDEPEND="virtual/glibc >=sys-libs/ncurses-5.2-r2"
+fi
+
+src_unpack() {
+ unpack ${A}
+ if [ "`use build`" ] ; then
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PF}-no-ncurses-gentoo.diff
+ touch *
+ fi
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] || [ "`use build`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/usr ${myconf} \
+ --mandir=/usr/share/man --infodir=/usr/share/info
+ try make ${MAKEOPTS}
+}
+
+src_install() {
+
+ if [ "`use build`" ] ; then
+ dobin makeinfo/makeinfo util/{install-info,texi2dvi,texindex}
+ else
+ try make DESTDIR=${D} infodir=${D}/usr/share/info install
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/mkinfodir
+
+ cd ${D}/usr/share/info
+ mv texinfo texinfo.info
+ for i in texinfo-*
+ do
+ mv ${i} texinfo.info-${i#texinfo-*}
+ done
+
+ cd ${S}
+
+ dodoc AUTHORS ChangeLog COPYING INTRODUCTION NEWS README TODO
+ docinto info
+ dodoc info/README
+ docinto makeinfo
+ dodoc makeinfo/README
+ fi
+}
+
+
+
+
+
+