summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-17 06:09:44 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-17 06:09:44 +0000
commit0fc5576b1a31b6724ed0ade6bb02db60b98e2107 (patch)
tree5bc9de591097fa976f81cf3c5e9fddd8e4d10f73 /sys-apps
parentupdate to latest debian patch, adds more manpages, also change to depend on k... (diff)
downloadgentoo-2-0fc5576b1a31b6724ed0ade6bb02db60b98e2107.tar.gz
gentoo-2-0fc5576b1a31b6724ed0ade6bb02db60b98e2107.tar.bz2
gentoo-2-0fc5576b1a31b6724ed0ade6bb02db60b98e2107.zip
update to latest debian patch, adds more manpages, also change to depend on kernel headers and not kernel sources
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/iproute/ChangeLog8
-rw-r--r--sys-apps/iproute/Manifest5
-rw-r--r--sys-apps/iproute/files/digest-iproute-20010824-r42
-rw-r--r--sys-apps/iproute/iproute-20010824-r4.ebuild77
4 files changed, 88 insertions, 4 deletions
diff --git a/sys-apps/iproute/ChangeLog b/sys-apps/iproute/ChangeLog
index f8e4e676b848..77d7fa816403 100644
--- a/sys-apps/iproute/ChangeLog
+++ b/sys-apps/iproute/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sys-apps/iproute
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/ChangeLog,v 1.21 2003/07/06 14:19:14 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/ChangeLog,v 1.22 2003/08/17 06:09:37 robbat2 Exp $
+*iproute-20010824-r4 (16 Aug 2003)
+
+ 16 Aug 2003; Robin H. Johnson <robbat2@gentoo.org>
+ iproute-20010824-r4.ebuild:
+ update to latest debian patch, adds more manpages, also change to depend on
+ kernel headers and not kernel sources
*iproute-20010824-r3 (04 May 2003)
diff --git a/sys-apps/iproute/Manifest b/sys-apps/iproute/Manifest
index d40d2ebc2e0b..92750a8933bb 100644
--- a/sys-apps/iproute/Manifest
+++ b/sys-apps/iproute/Manifest
@@ -1,8 +1,7 @@
-MD5 74d9175782203183ef6397b8f838802c iproute-20010824-r4.ebuild 2312
+MD5 f6d30412336db2561ff6ec430e75fdfe iproute-20010824-r4.ebuild 2333
MD5 49ff9aa06d64fee64fb74980492db238 iproute-20010824-r1.ebuild 2291
MD5 2c7996a751c63d1ecc97f3b56e102ade iproute-20010824-r3.ebuild 2280
-MD5 d1c4c2137ca2ac4ecfcd27a2e55ddd1d iproute-20010824-r4.ebuild~ 2252
-MD5 f0b2ac76d2bd285621762c5275166ae7 ChangeLog 2753
+MD5 ee30f5327573059a067639143b7dda85 ChangeLog 2991
MD5 9b13c46ad3540dd4bb5effd4ee8d82ac iproute-20010824-r2.ebuild 2287
MD5 99f9c691c1dd9a31f66cbcb7119471be tmp/9 1442
MD5 d90dd934543ac23d0cc8c5858e32fb47 tmp/10 1325
diff --git a/sys-apps/iproute/files/digest-iproute-20010824-r4 b/sys-apps/iproute/files/digest-iproute-20010824-r4
new file mode 100644
index 000000000000..ecb0144c535d
--- /dev/null
+++ b/sys-apps/iproute/files/digest-iproute-20010824-r4
@@ -0,0 +1,2 @@
+MD5 b05a4e375d9468be3a1dd3f0e83daee8 iproute2-2.4.7-now-ss010824.tar.gz 140139
+MD5 0214761b2a46ac5a5e9877e3fe8f3dcc iproute_20010824-10.diff.gz 44541
diff --git a/sys-apps/iproute/iproute-20010824-r4.ebuild b/sys-apps/iproute/iproute-20010824-r4.ebuild
new file mode 100644
index 000000000000..9cda212844f2
--- /dev/null
+++ b/sys-apps/iproute/iproute-20010824-r4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iproute/iproute-20010824-r4.ebuild,v 1.1 2003/08/17 06:09:37 robbat2 Exp $
+
+inherit eutils
+
+IUSE="tetex"
+
+DEBIANPATCH="${P/-/_}-10.diff.gz"
+SRCFILE="iproute2-2.4.7-now-ss${PV/20}.tar.gz"
+
+S=${WORKDIR}/iproute2
+DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
+SRC_URI="ftp://ftp.inr.ac.ru/ip-routing/${SRCFILE}
+ http://ftp.debian.org/debian/pool/main/i/iproute/${DEBIANPATCH}"
+HOMEPAGE="http://www.worldbank.ro/ip-routing/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips"
+
+# we install our kernel headers in /usr/include/linux
+# we should NEVER depend on /usr/src/linux existing ever
+# ~robbat2 2003/08/16
+DEPEND="virtual/os-headers
+ >=sys-apps/sed-4"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${SRCFILE}
+ cd ${S}
+
+ # Our patch does two things for us; First, it syncs up with Debian's
+ # iproute 20010824-9 package; Secondly, it adds htb3 support. The Debian
+ # patch tweaks the iproute compile so that we use an included pkt_sched.h
+ # header rather than looking at the one in /usr/src/linux/include/linux.
+ # This allows us to always enable HTB3 without compile problems;
+
+ epatch ${DISTDIR}/${DEBIANPATCH}
+
+ # why was this commented out? were the programs segfaulting/not working?
+ # they seem ok here when i compile with optimisations, so I'm re-enabling
+ # this patch. if there're problems, will gladly change back. ~woodchip
+
+ sed -i \
+ -e "s:-O2:${CFLAGS}:g" \
+ -e "s:-Werror::g" Makefile || die "sed Makefile failed"
+
+ # this next thing is required to enable diffserv
+ # (ATM support doesn't compile right now)
+
+ sed -i \
+ -e 's:DIFFSERV=n:DIFFSERV=y:g' \
+ -e 's:ATM=y:ATM=n:g' Config || die "sed Config failed"
+}
+
+src_compile() {
+ emake KERNEL_INCLUDE=/usr/include || die
+}
+
+src_install() {
+ into /
+ cd ${S}/ip ; dosbin ifcfg ip routef routel rtacct rtmon rtpr
+ cd ${S}/tc ; dosbin tc
+ cd ${S} ; dodoc README* RELNOTES
+
+ #install Debian man pages
+ doman ${S}/debian/manpages/*.[1-9]
+
+ docinto examples/diffserv ; dodoc examples/diffserv/*
+ docinto examples ; dodoc examples/*
+ dodir /etc/iproute2
+ insinto /etc/iproute2 ; doins ${S}/etc/iproute2/*
+ if use tetex; then
+ docinto ps ; dodoc doc/*.ps
+ fi
+}