summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-12 04:21:31 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-12 04:21:31 +0000
commit0999d330fe7044c50b47a4aab8b85d69c6a4327f (patch)
tree8c0dfd26c35218463dcac4a0dff9a0353773f460 /sys-apps
parentold (diff)
downloadgentoo-2-0999d330fe7044c50b47a4aab8b85d69c6a4327f.tar.gz
gentoo-2-0999d330fe7044c50b47a4aab8b85d69c6a4327f.tar.bz2
gentoo-2-0999d330fe7044c50b47a4aab8b85d69c6a4327f.zip
add a 2.6 check #72467 by Alexander Weber
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/mondo/mondo-0.9a.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/sys-apps/mondo/mondo-0.9a.ebuild b/sys-apps/mondo/mondo-0.9a.ebuild
index b0bf6fcc87c4..c6266b608690 100644
--- a/sys-apps/mondo/mondo-0.9a.ebuild
+++ b/sys-apps/mondo/mondo-0.9a.ebuild
@@ -1,38 +1,36 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/mondo/mondo-0.9a.ebuild,v 1.1 2004/08/12 15:47:09 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mondo/mondo-0.9a.ebuild,v 1.2 2005/02/12 04:21:31 vapier Exp $
DESCRIPTION="A System Health Monitor"
HOMEPAGE="http://mondo-daemon.sourceforge.net/"
-KEYWORDS="~x86"
-IUSE=""
-SLOT="0"
+SRC_URI="mirror://sourceforge/mondo-daemon/${P}.tar.bz2"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
DEPEND=">=sys-apps/lm-sensors-2.6.3"
-SRC_URI="mirror://sourceforge/mondo-daemon/${P}.tar.bz2"
-
-src_compile() {
- econf || die "Configure failed"
- emake || die
+pkg_setup() {
+ if [[ ${KV:0:3} != "2.4" ]] ; then
+ eerror "Sorry, but mondo only works with linux-2.4."
+ eerror "http://bugs.gentoo.org/show_bug.cgi?id=72467"
+ die "kernel not supported"
+ fi
}
src_install() {
einstall || die "Install failed"
-
- dodoc AUTHORS COPYING ChangeLog INSTALL README TODO
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/mondo.sh mondo
+ newinitd ${FILESDIR}/mondo.sh mondo
+ dodoc AUTHORS ChangeLog INSTALL README TODO
}
pkg_postinst() {
- einfo
einfo "The mondo system health monitor has been installed."
einfo
einfo "Don't forget to setup lm_sensors before starting mondo."
einfo "Run mondo-setup or edit /etc/mondo.conf manually and run"
einfo "'rc-update add mondo <runlevel>' to add mondo to a runlevel."
- einfo
}