summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-06-18 19:42:45 +0000
committerMike Frysinger <vapier@gentoo.org>2007-06-18 19:42:45 +0000
commit06f3b4fa939ab940821a893561a26e1251519f21 (patch)
treed014bd39477cd9ec1c063d15dc28137c8c1712a8 /sys-apps
parentDep fixes; tests are still failing on some platforms, opened upstream bug 552... (diff)
downloadgentoo-2-06f3b4fa939ab940821a893561a26e1251519f21.tar.gz
gentoo-2-06f3b4fa939ab940821a893561a26e1251519f21.tar.bz2
gentoo-2-06f3b4fa939ab940821a893561a26e1251519f21.zip
dont force help2man anymore and skip the man-pages update for uclibc
(Portage version: 2.1.3_rc3)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/coreutils-6.9-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sys-apps/coreutils/coreutils-6.9-r1.ebuild b/sys-apps/coreutils/coreutils-6.9-r1.ebuild
index eb10450ff9ab..72905f78d5e2 100644
--- a/sys-apps/coreutils/coreutils-6.9-r1.ebuild
+++ b/sys-apps/coreutils/coreutils-6.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-6.9-r1.ebuild,v 1.12 2007/06/13 12:19:30 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-6.9-r1.ebuild,v 1.13 2007/06/18 19:42:45 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs autotools
@@ -22,14 +22,13 @@ RESTRICT="confcache"
RDEPEND="selinux? ( sys-libs/libselinux )
acl? ( sys-apps/acl sys-apps/attr )
nls? ( >=sys-devel/gettext-0.15 )
- userland_GNU? ( >=sys-apps/man-pages-2.46 )
+ !elibc_uclibc? ( userland_GNU? ( >=sys-apps/man-pages-2.46 ) )
!net-mail/base64
>=sys-libs/ncurses-5.3-r5"
DEPEND="${RDEPEND}
=sys-devel/automake-1.9*
>=sys-devel/autoconf-2.61
- >=sys-devel/m4-1.4-r1
- sys-apps/help2man"
+ >=sys-devel/m4-1.4-r1"
pkg_setup() {
# fixup expr for #123342
@@ -64,11 +63,12 @@ src_unpack() {
chmod a+rx tests/sort/sort-mb-tests
chmod a+rx tests/ls/x-option
- # Since we've patched many .c files, the make process will
- # try to re-build the manpages by running `./bin --help`.
- # When cross-compiling, we can't do that since 'bin' isn't
- # a native binary, so let's just install outdated man-pages.
- tc-is-cross-compiler && touch man/*.1
+ # Since we've patched many .c files, the make process will try to
+ # re-build the manpages by running `./bin --help`. When doing a
+ # cross-compile, we can't do that since 'bin' isn't a native bin.
+ # Also, it's not like we changed the usage on any of these things,
+ # so let's just update the timestamps and skip the help2man step.
+ touch man/*.1
# There's no reason for this crap to use the private version
sed -i 's:__mempcpy:mempcpy:g' lib/*.c