summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-09-02 13:02:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-09-02 13:02:01 +0000
commit0650e91d1a6c318ee1d3403c31382252c47bcccd (patch)
tree47f86e2b3314e11af975b231cecb307b63bba4cc /sys-apps
parentAdd new Opera license, remove old. (diff)
downloadgentoo-2-0650e91d1a6c318ee1d3403c31382252c47bcccd.tar.gz
gentoo-2-0650e91d1a6c318ee1d3403c31382252c47bcccd.tar.bz2
gentoo-2-0650e91d1a6c318ee1d3403c31382252c47bcccd.zip
Version bump.
(Portage version: 2.2.0_alpha123-r1/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwids/ChangeLog7
-rw-r--r--sys-apps/hwids/hwids-20120831.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index f3f3cbce3555..53fa7cb662ee 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.17 2012/08/15 14:29:06 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.18 2012/09/02 13:02:01 flameeyes Exp $
+
+*hwids-20120831 (02 Sep 2012)
+
+ 02 Sep 2012; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20120831.ebuild:
+ Version bump.
*hwids-20120815 (15 Aug 2012)
diff --git a/sys-apps/hwids/hwids-20120831.ebuild b/sys-apps/hwids/hwids-20120831.ebuild
new file mode 100644
index 000000000000..e7cfebbb02dc
--- /dev/null
+++ b/sys-apps/hwids/hwids-20120831.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20120831.ebuild,v 1.1 2012/09/02 13:02:01 flameeyes Exp $
+
+EAPI="4"
+
+DESCRIPTION="Hardware (PCI, USB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+SRC_URI="https://github.com/gentoo/hwids/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S="${WORKDIR}"
+
+src_compile() {
+ cd "${S}"/gentoo-hwids-*
+
+ for file in {usb,pci}.ids; do
+ gzip -c ${file} > ${file}.gz || die
+ done
+}
+
+src_install() {
+ cd "${S}"/gentoo-hwids-*
+
+ insinto /usr/share/misc
+ doins {usb,pci}.ids{,.gz}
+
+ dodoc README.md
+}