summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-12-10 05:03:42 +0000
committerDonny Davies <woodchip@gentoo.org>2002-12-10 05:03:42 +0000
commit37f17fd3d77a030be9a5974a4de8d810209786ef (patch)
tree4b55a11968ac064728b49b80a592948c661f733c /sys-apps/xfsprogs
parentadd a valid shell reminder (diff)
downloadgentoo-2-37f17fd3d77a030be9a5974a4de8d810209786ef.tar.gz
gentoo-2-37f17fd3d77a030be9a5974a4de8d810209786ef.tar.bz2
gentoo-2-37f17fd3d77a030be9a5974a4de8d810209786ef.zip
chase latest XFS utils
Diffstat (limited to 'sys-apps/xfsprogs')
-rw-r--r--sys-apps/xfsprogs/ChangeLog6
-rw-r--r--sys-apps/xfsprogs/files/digest-xfsprogs-2.3.61
-rw-r--r--sys-apps/xfsprogs/xfsprogs-2.3.6.ebuild50
3 files changed, 56 insertions, 1 deletions
diff --git a/sys-apps/xfsprogs/ChangeLog b/sys-apps/xfsprogs/ChangeLog
index 99b6917c1052..4c84f9dddcfd 100644
--- a/sys-apps/xfsprogs/ChangeLog
+++ b/sys-apps/xfsprogs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/xfsprogs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/ChangeLog,v 1.7 2002/10/29 06:17:07 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/ChangeLog,v 1.8 2002/12/10 05:03:42 woodchip Exp $
+
+*xfsprogs-2.3.6 (09 Dec 2002)
+
+ 09 Dec 2002; Donny Davies <woodchip@gentoo.org> : Chase latest release.
*xfsprogs-2.2.2-r1 (29 Oct 2002)
diff --git a/sys-apps/xfsprogs/files/digest-xfsprogs-2.3.6 b/sys-apps/xfsprogs/files/digest-xfsprogs-2.3.6
new file mode 100644
index 000000000000..8138afd4b8d0
--- /dev/null
+++ b/sys-apps/xfsprogs/files/digest-xfsprogs-2.3.6
@@ -0,0 +1 @@
+MD5 661ffc4419a54195095da80e2aa17763 xfsprogs-2.3.6.src.tar.gz 758901
diff --git a/sys-apps/xfsprogs/xfsprogs-2.3.6.ebuild b/sys-apps/xfsprogs/xfsprogs-2.3.6.ebuild
new file mode 100644
index 000000000000..3e3da8c1e2d7
--- /dev/null
+++ b/sys-apps/xfsprogs/xfsprogs-2.3.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xfsprogs/xfsprogs-2.3.6.ebuild,v 1.1 2002/12/10 05:03:42 woodchip Exp $
+
+DESCRIPTION="xfs filesystem utilities"
+
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+S=${WORKDIR}/${P}
+
+DEPEND="sys-apps/e2fsprogs"
+
+src_compile() {
+ CFLAGS="`echo ${CFLAGS} | sed "s/ -O[2-9]/ -O1/g"`"
+ CXXFLAGS="`echo ${CXXFLAGS} | sed "s/ -O[2-9]/ -O1/g"`"
+
+ OPTIMIZER="${CFLAGS}"
+ DEBUG=-DNDEBUG
+
+ autoconf || die
+
+ ./configure --prefix=/usr \
+ --bindir=/bin \
+ --sbindir=/sbin \
+ --libdir=/lib \
+ --libexecdir=/lib \
+ --mandir=/usr/share/man || die "config failed"
+
+ cp include/builddefs include/builddefs.orig
+ sed -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ -e '/-S $(PKG/d' \
+ -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ include/builddefs.orig > include/builddefs || die "sed failed"
+
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} DK_INC_DIR=${D}/usr/include/disk install install-dev || die "make install failed"
+
+ cat ${S}/libhandle/.libs/libhandle.la | sed -e 's:installed=no:installed=yes:g' > ${D}/lib/libhandle.la
+
+ dosym /lib/libhandle.so.1 /lib/libhandle.so
+}