summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-13 23:38:19 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-13 23:38:19 +0000
commitd25226b00565574aaae2cdfae718789ca4f1603b (patch)
tree5fa62be291fd05975971b77fb42d37e7a71d371c /sys-apps/x86info
parentpic patch (Manifest recommit) (diff)
downloadgentoo-2-d25226b00565574aaae2cdfae718789ca4f1603b.tar.gz
gentoo-2-d25226b00565574aaae2cdfae718789ca4f1603b.tar.bz2
gentoo-2-d25226b00565574aaae2cdfae718789ca4f1603b.zip
old
Diffstat (limited to 'sys-apps/x86info')
-rw-r--r--sys-apps/x86info/files/digest-x86info-1.111
-rw-r--r--sys-apps/x86info/x86info-1.11.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/sys-apps/x86info/files/digest-x86info-1.11 b/sys-apps/x86info/files/digest-x86info-1.11
deleted file mode 100644
index 6c9e6314afd0..000000000000
--- a/sys-apps/x86info/files/digest-x86info-1.11
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c383845a7cbaa9c9e9784b1469e19950 x86info-1.11.tgz 40089
diff --git a/sys-apps/x86info/x86info-1.11.ebuild b/sys-apps/x86info/x86info-1.11.ebuild
deleted file mode 100644
index 93ac9fa255f8..000000000000
--- a/sys-apps/x86info/x86info-1.11.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.11.ebuild,v 1.9 2004/07/15 02:47:51 agriffis Exp $
-
-inherit eutils
-
-DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
-
-HOMEPAGE="http://www.codemonkey.org.uk/x86info/"
-
-SRC_URI="http://www.codemonkey.org.uk/x86info/${P}.tgz"
-
-LICENSE="GPL-2"
-
-SLOT="0"
-
-KEYWORDS="x86 -amd64 -ppc -sparc -mips -alpha -hppa"
-
-DEPEND="virtual/kernel"
-
-RDEPEND=""
-
-IUSE=""
-
-src_compile() {
- emake x86info CFLAGS="${CFLAGS}" ||die "emake failed"
-}
-
-src_install() {
- # binaries first
- into /usr
- dobin x86info
- # modules stuff next
- insinto /etc/modules.d
- newins ${FILESDIR}/x86info-modules.conf-rc x86info
- # now we all all the docs
- dodoc TODO README COPYING ChangeLog
- doman x86info.1
- cp -a results ${D}/usr/share/doc/${PF}
- # prepalldocs rocks! I saw it in net-fs/samba/samba-2.2.8
- prepalldocs
- # create device nodes for x86info
- # based off the scripts/makenode
- # there isn't any proper devfs support in cpuid/msr
- mkdir -p ${D}/dev/cpu
- local numprocs
- #subtract one because we are using a 0-based count
- numprocs=$((`grep '^processor' /proc/cpuinfo | wc -l`-1))
- for i in `seq 0 $numprocs`; do
- mkdir ${D}/dev/cpu/$i
- mknod ${D}/dev/cpu/$i/cpuid c 203 $i 2>/dev/null
- mknod ${D}/dev/cpu/$i/msr c 202 $i 2>/dev/null
- done
-}
-
-pkg_postinst() {
- ewarn "Your kernel must be built with the following options"
- ewarn "set to Y or M"
- ewarn " Processor type and features ->"
- ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
- ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
- # copied from media-libs/svgalib/svgalib-1.9.17
- [ "${ROOT}" = "/" ] && /sbin/modules-update &> /dev/null
-}