summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-14 15:08:42 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-14 15:08:42 +0000
commit18647e6b2f63bf60afc7f8ac700ddf3c63a43324 (patch)
tree971b130a3488a34bae256dedae7a905f537772fc /sys-apps/v86d
parentVersion bump, should fix bug #234514 (diff)
downloadgentoo-2-18647e6b2f63bf60afc7f8ac700ddf3c63a43324.tar.gz
gentoo-2-18647e6b2f63bf60afc7f8ac700ddf3c63a43324.tar.bz2
gentoo-2-18647e6b2f63bf60afc7f8ac700ddf3c63a43324.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'sys-apps/v86d')
-rw-r--r--sys-apps/v86d/ChangeLog7
-rw-r--r--sys-apps/v86d/v86d-0.1.7.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-apps/v86d/ChangeLog b/sys-apps/v86d/ChangeLog
index e1b38ebea36b..c6a35833a8ca 100644
--- a/sys-apps/v86d/ChangeLog
+++ b/sys-apps/v86d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/v86d
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.21 2008/09/08 22:46:21 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/ChangeLog,v 1.22 2008/09/14 15:08:42 spock Exp $
+
+*v86d-0.1.7 (14 Sep 2008)
+
+ 14 Sep 2008; Michał Januszewski <spock@gentoo.org> +v86d-0.1.7.ebuild:
+ Version bump.
09 Sep 2008; Michał Januszewski <spock@gentoo.org> -v86d-0.1.5.ebuild,
-v86d-0.1.5.1.ebuild:
diff --git a/sys-apps/v86d/v86d-0.1.7.ebuild b/sys-apps/v86d/v86d-0.1.7.ebuild
new file mode 100644
index 000000000000..1d8332759f19
--- /dev/null
+++ b/sys-apps/v86d/v86d-0.1.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.7.ebuild,v 1.1 2008/09/14 15:08:42 spock Exp $
+
+inherit linux-info multilib
+
+DESCRIPTION="A daemon to run x86 code in an emulated environment."
+HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
+SRC_URI="http://dev.gentoo.org/~spock/projects/uvesafb/archive/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug x86emu"
+
+DEPEND="dev-libs/klibc"
+RDEPEND=""
+
+S="${WORKDIR}/${P//_*/}"
+
+pkg_setup() {
+ if [ -z "$(grep V86D /usr/$(get_libdir)/klibc/include/linux/connector.h)" ]; then
+ eerror "You need to compile klibc against a kernel tree patched with uvesafb"
+ eerror "prior to merging this package."
+ die "Kernel not patched with uvesafb."
+ fi
+ linux-info_pkg_setup
+}
+
+src_compile() {
+ local myconf=""
+ if use x86emu ; then
+ myconf="--with-x86emu"
+ fi
+
+ ./configure --with-klibc $(use_with debug) ${myconf}
+ make KDIR="${KV_DIR}" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README ChangeLog
+
+ insinto /usr/share/${PN}
+ doins misc/initramfs
+}
+
+pkg_postinst() {
+ elog "If you wish to place v86d into an initramfs image, you might want to use"
+ elog "'/usr/share/${PN}/initramfs' in your kernel's CONFIG_INITRAMFS_SOURCE."
+}