summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-11-03 23:38:43 +0000
committerMichael Januszewski <spock@gentoo.org>2008-11-03 23:38:43 +0000
commit19eab6d4d0e464c2384e3d49cb3cf7664c444463 (patch)
tree8f2a9914f45a6b2ea98fda6ada2dcd25497bb97b /sys-apps/v86d/v86d-0.1.9.ebuild
parentNew version for GNOME 2.24. Update code to use xrandr 1.2 capabilities, moder... (diff)
downloadgentoo-2-19eab6d4d0e464c2384e3d49cb3cf7664c444463.tar.gz
gentoo-2-19eab6d4d0e464c2384e3d49cb3cf7664c444463.tar.bz2
gentoo-2-19eab6d4d0e464c2384e3d49cb3cf7664c444463.zip
Add a fix for bug #245254.
(Portage version: 2.2_rc13/cvs/Linux 2.6.27 x86_64)
Diffstat (limited to 'sys-apps/v86d/v86d-0.1.9.ebuild')
-rw-r--r--sys-apps/v86d/v86d-0.1.9.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-apps/v86d/v86d-0.1.9.ebuild b/sys-apps/v86d/v86d-0.1.9.ebuild
index 245308776b0a..8252b76eb366 100644
--- a/sys-apps/v86d/v86d-0.1.9.ebuild
+++ b/sys-apps/v86d/v86d-0.1.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.9.ebuild,v 1.2 2008/10/04 09:38:55 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/v86d/v86d-0.1.9.ebuild,v 1.3 2008/11/03 23:38:43 spock Exp $
-inherit linux-info multilib
+inherit eutils linux-info multilib
DESCRIPTION="A daemon to run x86 code in an emulated environment."
HOMEPAGE="http://dev.gentoo.org/~spock/projects/uvesafb/"
@@ -27,6 +27,12 @@ pkg_setup() {
linux-info_pkg_setup
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-prot_write.patch"
+}
+
src_compile() {
./configure --with-klibc $(use_with debug) $(use_with x86emu) || die
emake KDIR="${KV_DIR}" || die