summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-07 05:31:33 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-07 05:31:33 +0000
commite988b10d0841bae4c48eafdbb283bd95a9dcc72e (patch)
tree3b23d4824673795e622f1601c9a9842450b9fb0e /sys-apps/util-linux
parentmake more flexible based on $PV, block setarch, and tweak file install to mat... (diff)
downloadgentoo-2-e988b10d0841bae4c48eafdbb283bd95a9dcc72e.tar.gz
gentoo-2-e988b10d0841bae4c48eafdbb283bd95a9dcc72e.tar.bz2
gentoo-2-e988b10d0841bae4c48eafdbb283bd95a9dcc72e.zip
Version bump.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog8
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.13_rc13
-rw-r--r--sys-apps/util-linux/util-linux-2.13_rc1.ebuild73
3 files changed, 83 insertions, 1 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 276ff1c83675..76313ecb4ab7 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.193 2007/06/15 23:30:31 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.194 2007/07/07 05:31:33 vapier Exp $
+
+*util-linux-2.13_rc1 (07 Jul 2007)
+
+ 07 Jul 2007; Mike Frysinger <vapier@gentoo.org>
+ +util-linux-2.13_rc1.ebuild:
+ Version bump.
15 Jun 2007; Joe Peterson <lavajoe@gentoo.org> util-linux-2.12r-r7.ebuild:
Add blocker: sys-apps/more (since both provide the "more" pager)
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.13_rc1 b/sys-apps/util-linux/files/digest-util-linux-2.13_rc1
new file mode 100644
index 000000000000..dd3a28aa5b8c
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.13_rc1
@@ -0,0 +1,3 @@
+MD5 0dd0d97f20118d07f63a40769667353b util-linux-ng-2.13-rc1.tar.bz2 2784788
+RMD160 94989bc9bd5dff3c34690324be83ed78476f597a util-linux-ng-2.13-rc1.tar.bz2 2784788
+SHA256 e0aeb0b619e19fdf0fe154784644215e1c4f3d4352173e94724c68401dbd8567 util-linux-ng-2.13-rc1.tar.bz2 2784788
diff --git a/sys-apps/util-linux/util-linux-2.13_rc1.ebuild b/sys-apps/util-linux/util-linux-2.13_rc1.ebuild
new file mode 100644
index 000000000000..430b21a88287
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.13_rc1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13_rc1.ebuild,v 1.1 2007/07/07 05:31:33 vapier Exp $
+
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
+inherit eutils git
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-ng-${MY_PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+else
+ SRC_URI="http://www.kernel.org/pub/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls old-linux selinux"
+
+RDEPEND="!sys-process/schedutils
+ !sys-apps/setarch
+ >=sys-libs/ncurses-5.2-r2
+ >=sys-fs/e2fsprogs-1.34
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/os-headers"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ cd "${S}"
+ ./autogen.sh || die
+ else
+ unpack ${A}
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-fsprobe=blkid \
+ $(use_enable nls) \
+ --enable-agetty \
+ --enable-cramfs \
+ $(use_enable old-linux elvtune) \
+ --disable-init \
+ --disable-kill \
+ --disable-last \
+ --disable-mesg \
+ --enable-partx \
+ --enable-raw \
+ --enable-rdev \
+ --enable-rename \
+ --disable-reset \
+ --disable-login-utils \
+ --enable-schedutils \
+ --disable-wall \
+ --enable-write \
+ --without-pam \
+ $(use_with selinux) \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS NEWS README* TODO docs/*
+}