summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-24 08:46:36 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-24 08:46:36 +0000
commit0ee987c6d09df68dc51de43c81654d5f30ccf6ce (patch)
treef2a947a71f669a406edff25b5265d9cb4b957ff4 /sys-apps/util-linux
parentarm KEYWORD (diff)
downloadgentoo-2-0ee987c6d09df68dc51de43c81654d5f30ccf6ce.tar.gz
gentoo-2-0ee987c6d09df68dc51de43c81654d5f30ccf6ce.tar.bz2
gentoo-2-0ee987c6d09df68dc51de43c81654d5f30ccf6ce.zip
touchups
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/util-linux-2.11z-r8.ebuild15
-rw-r--r--sys-apps/util-linux/util-linux-2.11z-r9.ebuild26
2 files changed, 18 insertions, 23 deletions
diff --git a/sys-apps/util-linux/util-linux-2.11z-r8.ebuild b/sys-apps/util-linux/util-linux-2.11z-r8.ebuild
index 13bbfca25cd8..1d55b94187cd 100644
--- a/sys-apps/util-linux/util-linux-2.11z-r8.ebuild
+++ b/sys-apps/util-linux/util-linux-2.11z-r8.ebuild
@@ -1,31 +1,29 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11z-r8.ebuild,v 1.3 2004/02/27 19:28:37 seemant Exp $
-
-IUSE="crypt nls static pam"
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11z-r8.ebuild,v 1.4 2004/04/24 08:46:36 vapier Exp $
inherit eutils flag-o-matic
## see below for details on pic.patch
# Added back for now until other archs can be tested.
-S="${WORKDIR}/${P}"
CRYPT_PATCH_P="${P}-crypt-gentoo"
DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.bz2
crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
KEYWORDS="x86 amd64 ppc sparc alpha mips hppa"
SLOT="0"
LICENSE="GPL-2"
+IUSE="crypt nls static pam"
DEPEND="virtual/glibc
>=sys-apps/sed-4.0.5
>=sys-libs/ncurses-5.2-r2
pam? ( sys-apps/pam-login )"
-
-RDEPEND="${DEPEND} dev-lang/perl
+RDEPEND="${DEPEND}
+ dev-lang/perl
nls? ( sys-devel/gettext )"
src_unpack() {
@@ -83,7 +81,7 @@ src_unpack() {
-e "s:SUIDMODE=.*4755:SUIDMODE=4711:" \
MCONFIG || die "MCONFIG sed"
- if [ -z "`use nls`" ] ; then
+ if ! use nls ; then
sed -i -e 's/DISABLE_NLS=no/DISABLE_NLS=yes/' MCONFIG ||
die "MCONFIG nls sed"
fi
@@ -115,4 +113,3 @@ src_install() {
docinto examples
dodoc example.files/*
}
-
diff --git a/sys-apps/util-linux/util-linux-2.11z-r9.ebuild b/sys-apps/util-linux/util-linux-2.11z-r9.ebuild
index 7db027559c8c..a83065bf2717 100644
--- a/sys-apps/util-linux/util-linux-2.11z-r9.ebuild
+++ b/sys-apps/util-linux/util-linux-2.11z-r9.ebuild
@@ -1,30 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11z-r9.ebuild,v 1.4 2004/04/20 03:44:38 lv Exp $
-
-IUSE="crypt nls static pam"
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.11z-r9.ebuild,v 1.5 2004/04/24 08:46:36 vapier Exp $
inherit eutils flag-o-matic
-## see below for details on pic.patch
-case ${ARCH} in
- "x86"|"hppa"|"sparc64"|"ppc"|"mips"|"amd64")
- ;;
- *)
- filter-flags -fPIC
- ;;
-esac
-
-S="${WORKDIR}/${P}"
CRYPT_PATCH_P="${P}-crypt-gentoo"
DESCRIPTION="Various useful Linux utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
SRC_URI="mirror://kernel/linux/utils/${PN}/${P}.tar.bz2
crypt? ( mirror://gentoo/${CRYPT_PATCH_P}.patch.bz2 )"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha mips ~hppa"
SLOT="0"
LICENSE="GPL-2"
+IUSE="crypt nls static pam"
DEPEND="virtual/glibc
>=sys-apps/sed-4.0.5
@@ -86,6 +75,15 @@ src_unpack() {
#enable pam only if we use it
use pam && sed -i "s:HAVE_PAM=no:HAVE_PAM=yes:" MCONFIG
+ ## see below for details on pic.patch
+ case ${ARCH} in
+ "x86"|"hppa"|"sparc64"|"ppc"|"mips"|"amd64")
+ ;;
+ *)
+ filter-flags -fPIC
+ ;;
+ esac
+
sed -i \
-e "s:-pipe -O2 \$(CPUOPT) -fomit-frame-pointer:${CFLAGS}:" \
-e "s:CPU=.*:CPU=${CHOST%%-*}:" \