summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-04 18:35:00 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-04 18:35:00 +0000
commitdd12ad184403f157ec7a7f2b1b37fc437d4c1573 (patch)
treeb18d8c7da5f3d6069d4b3cc656c03db96e5a5cf6 /sys-apps/util-linux/util-linux-2.21.2.ebuild
parentRemoved old versions and files (diff)
downloadgentoo-2-dd12ad184403f157ec7a7f2b1b37fc437d4c1573.tar.gz
gentoo-2-dd12ad184403f157ec7a7f2b1b37fc437d4c1573.tar.bz2
gentoo-2-dd12ad184403f157ec7a7f2b1b37fc437d4c1573.zip
Removed old versions and files
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps/util-linux/util-linux-2.21.2.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-2.21.2.ebuild125
1 files changed, 0 insertions, 125 deletions
diff --git a/sys-apps/util-linux/util-linux-2.21.2.ebuild b/sys-apps/util-linux/util-linux-2.21.2.ebuild
deleted file mode 100644
index 682285c35e15..000000000000
--- a/sys-apps/util-linux/util-linux-2.21.2.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.21.2.ebuild,v 1.11 2012/11/28 23:03:40 ssuominen Exp $
-
-EAPI="3"
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
-AUTOTOOLS_AUTO_DEPEND="no"
-inherit eutils toolchain-funcs libtool flag-o-matic autotools
-if [[ ${PV} == "9999" ]] ; then
- inherit git-2 autotools
- #KEYWORDS=""
-else
- KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
-else
- SRC_URI="mirror://kernel/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz"
-fi
-
-LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
-SLOT="0"
-IUSE="+cramfs crypt ddate ncurses nls old-linux perl selinux slang static-libs uclibc udev unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- !<sys-apps/sysvinit-2.88-r3
- !<sys-libs/e2fsprogs-libs-1.41.8
- !<sys-fs/e2fsprogs-1.41.8
- cramfs? ( sys-libs/zlib )
- ncurses? ( >=sys-libs/ncurses-5.2-r2 )
- perl? ( dev-lang/perl )
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )
- udev? ( virtual/udev )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers
- uclibc? ( ${AUTOTOOLS_DEPEND} )"
-
-src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
- po/update-potfiles
- eautoreconf
- fi
- if use uclibc ; then
- epatch "${FILESDIR}"/${PN}-2.21.1-no-printf-alloc.patch #406303
- eautoreconf
- fi
- elibtoolize
-}
-
-lfs_fallocate_test() {
- # Make sure we can use fallocate with LFS #300307
- cat <<-EOF > "${T}"/fallocate.c
- #define _GNU_SOURCE
- #include <fcntl.h>
- main() { return fallocate(0, 0, 0, 0); }
- EOF
- append-lfs-flags
- $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.c -o /dev/null >/dev/null 2>&1 \
- || export ac_cv_func_fallocate=no
- rm -f "${T}"/fallocate.c
-}
-
-src_configure() {
- lfs_fallocate_test
- econf \
- --enable-fs-paths-extra=/usr/sbin \
- $(use_enable nls) \
- --enable-agetty \
- $(use_enable cramfs) \
- $(use_enable ddate) \
- $(use_enable old-linux elvtune) \
- --with-ncurses=$(usex ncurses $(usex unicode auto yes) no) \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- $(use_with selinux) \
- $(use_with slang) \
- $(use_enable static-libs static) \
- $(use_with udev) \
- $(tc-has-tls || echo --disable-tls)
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS NEWS README* Documentation/{TODO,*.txt}
-
- if ! use perl ; then #284093
- rm "${ED}"/usr/bin/chkdupexe || die
- rm "${ED}"/usr/share/man/man1/chkdupexe.1 || die
- fi
-
- # need the libs in /
- gen_usr_ldscript -a blkid mount uuid
- # e2fsprogs-libs didnt install .la files, and .pc work fine
- find "${ED}" -name '*.la' -delete
-
- if use crypt ; then
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
- fi
-}
-
-pkg_postinst() {
- elog "The agetty util now clears the terminal by default. You"
- elog "might want to add --noclear to your /etc/inittab lines."
-}