summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Becker <geoman@gentoo.org>2006-04-21 16:02:12 +0000
committerStephen Becker <geoman@gentoo.org>2006-04-21 16:02:12 +0000
commit7ee0cbe4cf3258e120c329c36495ce5f90b68c3a (patch)
treeca4018e23458982c7850877270904a05f7c23596 /sys-apps/util-linux/util-linux-2.12r-r4.ebuild
parentDon't depend on expect. Thanks to Emil Beinroth in bug #98864. (diff)
downloadgentoo-2-7ee0cbe4cf3258e120c329c36495ce5f90b68c3a.tar.gz
gentoo-2-7ee0cbe4cf3258e120c329c36495ce5f90b68c3a.tar.bz2
gentoo-2-7ee0cbe4cf3258e120c329c36495ce5f90b68c3a.zip
use lseek instead of llseek for mips, and mark -r3 stable on mips
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-apps/util-linux/util-linux-2.12r-r4.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-2.12r-r4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-apps/util-linux/util-linux-2.12r-r4.ebuild b/sys-apps/util-linux/util-linux-2.12r-r4.ebuild
index 0f0dd93cb775..2005169da57b 100644
--- a/sys-apps/util-linux/util-linux-2.12r-r4.ebuild
+++ b/sys-apps/util-linux/util-linux-2.12r-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12r-r4.ebuild,v 1.1 2006/04/11 00:36:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.12r-r4.ebuild,v 1.2 2006/04/21 16:02:12 geoman Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -114,6 +114,9 @@ src_unpack() {
# Patches from Fedora
epatch "${FILESDIR}"/${PN}-2.12r-umount-nosysfs.patch
+ # fix mips n32 (no llseek syscall)
+ epatch "${FILESDIR}"/${PN}-2.12-mips-lseek.patch
+
# Enable random features
local mconfigs="MCONFIG"
use old-crypt && mconfigs="${mconfigs} ${OLD_CRYPT_P}/MCONFIG"