summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-09-25 09:01:31 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-09-25 09:01:31 +0000
commit0984cc813e548ccb81ff14045001839cac87f20b (patch)
tree354c083489174d9d839dbe93e2a129b0660de96e /sys-apps/usbutils
parentDrop autotools eclass. (diff)
downloadgentoo-2-0984cc813e548ccb81ff14045001839cac87f20b.tar.gz
gentoo-2-0984cc813e548ccb81ff14045001839cac87f20b.tar.bz2
gentoo-2-0984cc813e548ccb81ff14045001839cac87f20b.zip
Remove ugly has_version usage and use LIBUSBX_API_VERSION in the patch.
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/usbutils')
-rw-r--r--sys-apps/usbutils/ChangeLog6
-rw-r--r--sys-apps/usbutils/files/usbutils-006-libusbx-1.0.13.patch7
-rw-r--r--sys-apps/usbutils/usbutils-006.ebuild5
3 files changed, 12 insertions, 6 deletions
diff --git a/sys-apps/usbutils/ChangeLog b/sys-apps/usbutils/ChangeLog
index 42e6d81e87f3..0fb700e8ad3d 100644
--- a/sys-apps/usbutils/ChangeLog
+++ b/sys-apps/usbutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/usbutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.143 2012/09/24 11:47:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/ChangeLog,v 1.144 2012/09/25 09:01:31 ssuominen Exp $
+
+ 25 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> usbutils-006.ebuild,
+ files/usbutils-006-libusbx-1.0.13.patch:
+ Remove ugly has_version usage and use LIBUSBX_API_VERSION in the patch.
24 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> -usbutils-005.ebuild,
-usbutils-005-r1.ebuild, -files/usbutils-005-missing-includes.patch:
diff --git a/sys-apps/usbutils/files/usbutils-006-libusbx-1.0.13.patch b/sys-apps/usbutils/files/usbutils-006-libusbx-1.0.13.patch
index f9a1334ebf97..16f09b763914 100644
--- a/sys-apps/usbutils/files/usbutils-006-libusbx-1.0.13.patch
+++ b/sys-apps/usbutils/files/usbutils-006-libusbx-1.0.13.patch
@@ -3,12 +3,15 @@ http://github.com/libusbx/libusbx/commit/3f513b62467d1842ec0771aaec01fde2f57bfb9
--- lsusb.c
+++ lsusb.c
-@@ -437,7 +437,7 @@
+@@ -437,7 +437,11 @@
printf(" Remote Wakeup\n");
if (config->bmAttributes & 0x10)
printf(" Battery Powered\n");
-- printf(" MaxPower %5umA\n", config->MaxPower * 2);
++ #if defined(LIBUSBX_API_VERSION) && (LIBUSBX_API_VERSION >= 0x01000100)
+ printf(" MaxPower %5umA\n", config->bMaxPower * 2);
++ #else
+ printf(" MaxPower %5umA\n", config->MaxPower * 2);
++ #endif
/* avoid re-ordering or hiding descriptors for display */
if (config->extra_length) {
diff --git a/sys-apps/usbutils/usbutils-006.ebuild b/sys-apps/usbutils/usbutils-006.ebuild
index b45130d5a03f..8710a5ac2fe6 100644
--- a/sys-apps/usbutils/usbutils-006.ebuild
+++ b/sys-apps/usbutils/usbutils-006.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-006.ebuild,v 1.2 2012/09/24 11:45:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-006.ebuild,v 1.3 2012/09/25 09:01:31 ssuominen Exp $
EAPI="4"
@@ -33,8 +33,7 @@ pkg_setup() {
}
src_prepare() {
- has_version ">=dev-libs/libusbx-1.0.13" && \
- epatch "${FILESDIR}"/${P}-libusbx-1.0.13.patch
+ epatch "${FILESDIR}"/${P}-libusbx-1.0.13.patch
if use python; then
python_convert_shebangs 2 lsusb.py