summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-05-14 21:20:24 +0000
committerHanno Böck <hanno@gentoo.org>2010-05-14 21:20:24 +0000
commitd4e87849f6cacfec7a8e66c97d7945b4a873fd8a (patch)
treeca9453276517fef05bd4e727612a613251eb5a18 /sys-apps/usb_modeswitch
parentVersion bump wrt #319771 without HAL support wrt #313389. (diff)
downloadgentoo-2-d4e87849f6cacfec7a8e66c97d7945b4a873fd8a.tar.gz
gentoo-2-d4e87849f6cacfec7a8e66c97d7945b4a873fd8a.tar.bz2
gentoo-2-d4e87849f6cacfec7a8e66c97d7945b4a873fd8a.zip
usb_modeswitch version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/usb_modeswitch')
-rw-r--r--sys-apps/usb_modeswitch/ChangeLog9
-rw-r--r--sys-apps/usb_modeswitch/files/usb_modeswitch-1.1.2-makefile.diff25
-rw-r--r--sys-apps/usb_modeswitch/usb_modeswitch-1.1.2.ebuild37
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-apps/usb_modeswitch/ChangeLog b/sys-apps/usb_modeswitch/ChangeLog
index 72ff0794d31e..36359f968b9a 100644
--- a/sys-apps/usb_modeswitch/ChangeLog
+++ b/sys-apps/usb_modeswitch/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/usb_modeswitch
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/ChangeLog,v 1.6 2010/04/05 11:51:04 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/ChangeLog,v 1.7 2010/05/14 21:20:24 hanno Exp $
+
+*usb_modeswitch-1.1.2 (14 May 2010)
+
+ 14 May 2010; Hanno Boeck <hanno@gentoo.org> +usb_modeswitch-1.1.2.ebuild,
+ +files/usb_modeswitch-1.1.2-makefile.diff:
+ Version bump, now needs usb_modeswitch-data for udev rules. Patch to
+ respect LDFLAGS and to make dodir command unneccessary.
*usb_modeswitch-1.1.1 (05 Apr 2010)
diff --git a/sys-apps/usb_modeswitch/files/usb_modeswitch-1.1.2-makefile.diff b/sys-apps/usb_modeswitch/files/usb_modeswitch-1.1.2-makefile.diff
new file mode 100644
index 000000000000..80bc6abb900e
--- /dev/null
+++ b/sys-apps/usb_modeswitch/files/usb_modeswitch-1.1.2-makefile.diff
@@ -0,0 +1,25 @@
+--- usb-modeswitch-1.1.2/Makefile 2010-04-17 20:27:11.000000000 +0200
++++ usb-modeswitch-1.1.2-1/Makefile 2010-05-14 21:00:13.000000000 +0200
+@@ -15,17 +15,16 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) -o $(PROG) $(OBJS) $(CFLAGS)
++ $(CC) -o $(PROG) $(OBJS) $(CFLAGS) $(LDFLAGS)
+
+ clean:
+ $(RM) usb_modeswitch
+
+ install: all
+- install -d $(SBINDIR)
+- install --mode=755 usb_modeswitch $(SBINDIR)/usb_modeswitch
+- install --mode=755 usb_modeswitch.tcl $(UDEVDIR)/usb_modeswitch
+- install --mode=644 usb_modeswitch.conf $(ETCDIR)/usb_modeswitch.conf
+- install --mode=644 usb_modeswitch.1 $(MANDIR)/usb_modeswitch.1
++ install -D --mode=755 usb_modeswitch $(SBINDIR)/usb_modeswitch
++ install -D --mode=755 usb_modeswitch.tcl $(UDEVDIR)/usb_modeswitch
++ install -D --mode=644 usb_modeswitch.conf $(ETCDIR)/usb_modeswitch.conf
++ install -D --mode=644 usb_modeswitch.1 $(MANDIR)/usb_modeswitch.1
+
+
+ uninstall:
diff --git a/sys-apps/usb_modeswitch/usb_modeswitch-1.1.2.ebuild b/sys-apps/usb_modeswitch/usb_modeswitch-1.1.2.ebuild
new file mode 100644
index 000000000000..96cf69ef0082
--- /dev/null
+++ b/sys-apps/usb_modeswitch/usb_modeswitch-1.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/usb_modeswitch-1.1.2.ebuild,v 1.1 2010/05/14 21:20:24 hanno Exp $
+
+EAPI="2"
+inherit multilib toolchain-funcs eutils
+
+MY_PN="${PN/_/-}"
+MY_P="${MY_PN}-${PV}"
+DATA_VER="20100418"
+DESCRIPTION="USB_ModeSwitch is a tool for controlling 'flip flop' (multiple devices) USB gear like UMTS sticks"
+HOMEPAGE="http://www.draisberghof.de/usb_modeswitch/"
+SRC_URI="http://www.draisberghof.de/usb_modeswitch/${MY_P}.tar.bz2
+ http://www.draisberghof.de/usb_modeswitch/usb-modeswitch-data-${DATA_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=virtual/libusb-0*"
+RDEPEND="${DEPEND}
+ dev-lang/tcl"
+# TCL rdep is not an error. The runner script is written in it.
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.diff"
+}
+
+src_install() {
+ UDEVDIR="/$(get_libdir)/udev/"
+ emake install DESTDIR="${D}" UDEVDIR="${D}/${UDEVDIR}" || die
+ cd "${WORKDIR}/usb-modeswitch-data-${DATA_VER}"
+ emake files-install DESTDIR="${D}" UDEVDIR="${D}/${UDEVDIR}" || die
+}