summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2012-01-01 17:50:04 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2012-01-01 17:50:04 +0000
commitb6f600b3a0df0d204ba5787c3ffeab5f5159fc92 (patch)
tree82d3a188f7c0d466a4a6c239963db061c3c9163c /sys-apps/usb_modeswitch
parentalpha/ia64/s390/sh/sparc stable wrt #394039 (diff)
downloadgentoo-2-b6f600b3a0df0d204ba5787c3ffeab5f5159fc92.tar.gz
gentoo-2-b6f600b3a0df0d204ba5787c3ffeab5f5159fc92.tar.bz2
gentoo-2-b6f600b3a0df0d204ba5787c3ffeab5f5159fc92.zip
Version bump.
(Portage version: 2.2.0_alpha59_p57/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/usb_modeswitch')
-rw-r--r--sys-apps/usb_modeswitch/ChangeLog10
-rw-r--r--sys-apps/usb_modeswitch/usb_modeswitch-1.2.1.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-apps/usb_modeswitch/ChangeLog b/sys-apps/usb_modeswitch/ChangeLog
index b1e46f671ea2..9d9ed7627b7f 100644
--- a/sys-apps/usb_modeswitch/ChangeLog
+++ b/sys-apps/usb_modeswitch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/usb_modeswitch
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/ChangeLog,v 1.21 2011/10/04 21:31:28 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/ChangeLog,v 1.22 2012/01/01 17:50:04 rafaelmartins Exp $
+
+*usb_modeswitch-1.2.1 (01 Jan 2012)
+
+ 01 Jan 2012; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +usb_modeswitch-1.2.1.ebuild:
+ Version bump.
04 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
usb_modeswitch-1.1.9.ebuild:
diff --git a/sys-apps/usb_modeswitch/usb_modeswitch-1.2.1.ebuild b/sys-apps/usb_modeswitch/usb_modeswitch-1.2.1.ebuild
new file mode 100644
index 000000000000..e92d3aa9f048
--- /dev/null
+++ b/sys-apps/usb_modeswitch/usb_modeswitch-1.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usb_modeswitch/usb_modeswitch-1.2.1.ebuild,v 1.1 2012/01/01 17:50:04 rafaelmartins Exp $
+
+EAPI="4"
+inherit multilib toolchain-funcs
+
+MY_PN="${PN/_/-}"
+MY_P="${MY_PN}-${PV}"
+DATA_VER="20111023"
+
+DESCRIPTION="USB_ModeSwitch is a tool for controlling 'flip flop' (multiple devices) USB gear like UMTS sticks"
+HOMEPAGE="http://www.draisberghof.de/usb_modeswitch/"
+SRC_URI="http://www.draisberghof.de/${PN}/${MY_P}.tar.bz2
+ http://www.draisberghof.de/${PN}/${MY_PN}-data-${DATA_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/libusb:0"
+RDEPEND="${DEPEND}
+ dev-lang/tcl" # usb_modeswitch script is tcl
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i -e 's/-s //' Makefile || die 'sed failed.'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local udevdir="${D}/$(get_libdir)/udev"
+ emake DESTDIR="${D}" UDEVDIR="${udevdir}" install
+
+ cd ../"${MY_PN}-data-${DATA_VER}"
+ emake DESTDIR="${D}" RULESDIR="${udevdir}/rules.d" files-install db-install
+}