summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-04-08 21:35:04 +0000
committerZac Medico <zmedico@gentoo.org>2015-04-08 21:35:04 +0000
commit5f928adfdb875eb6cae11929086f5a5253bceca3 (patch)
tree92f33df359c6ae1ca69d0075e155a6511a05252e /sys-apps/unscd
parentamd64/x86 stable, drop old (diff)
downloadgentoo-2-5f928adfdb875eb6cae11929086f5a5253bceca3.tar.gz
gentoo-2-5f928adfdb875eb6cae11929086f5a5253bceca3.tar.bz2
gentoo-2-5f928adfdb875eb6cae11929086f5a5253bceca3.zip
Add systemd service unit for bug 546004.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key FDE8EF85AE5719A3)
Diffstat (limited to 'sys-apps/unscd')
-rw-r--r--sys-apps/unscd/ChangeLog10
-rw-r--r--sys-apps/unscd/files/unscd-tmpfiles.conf1
-rw-r--r--sys-apps/unscd/files/unscd.service18
-rw-r--r--sys-apps/unscd/unscd-0.52-r2.ebuild (renamed from sys-apps/unscd/unscd-0.52-r1.ebuild)8
4 files changed, 32 insertions, 5 deletions
diff --git a/sys-apps/unscd/ChangeLog b/sys-apps/unscd/ChangeLog
index 9bddc82dd3d2..66e3ea041327 100644
--- a/sys-apps/unscd/ChangeLog
+++ b/sys-apps/unscd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/unscd
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/unscd/ChangeLog,v 1.19 2014/10/17 20:51:31 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/unscd/ChangeLog,v 1.20 2015/04/08 21:35:04 zmedico Exp $
+
+*unscd-0.52-r2 (08 Apr 2015)
+
+ 08 Apr 2015; Zac Medico <zmedico@gentoo.org> +files/unscd-tmpfiles.conf,
+ +files/unscd.service, +unscd-0.52-r2.ebuild, -unscd-0.52-r1.ebuild:
+ Add systemd service unit for bug 546004.
17 Oct 2014; Tim Harder <radhermit@gentoo.org> -unscd-0.39.ebuild,
-unscd-0.45.ebuild, -unscd-0.47.ebuild, -unscd-0.48.ebuild,
diff --git a/sys-apps/unscd/files/unscd-tmpfiles.conf b/sys-apps/unscd/files/unscd-tmpfiles.conf
new file mode 100644
index 000000000000..b5f25f6c5bb1
--- /dev/null
+++ b/sys-apps/unscd/files/unscd-tmpfiles.conf
@@ -0,0 +1 @@
+d /run/nscd 0755 root root -
diff --git a/sys-apps/unscd/files/unscd.service b/sys-apps/unscd/files/unscd.service
new file mode 100644
index 000000000000..d7c932b9587d
--- /dev/null
+++ b/sys-apps/unscd/files/unscd.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Name Service Cache Daemon (unscd)
+Wants=ldap.service network-online.target slapd.service
+After=ldap.service network-online.target nss-lookup.target nss-user-lookup.target slapd.service
+
+[Service]
+Type=forking
+PIDFile=/run/nscd/nscd.pid
+ExecStart=/usr/sbin/unscd
+ExecStop=/usr/sbin/nscd --shutdown
+ExecReload=/usr/sbin/nscd -i passwd
+ExecReload=/usr/sbin/nscd -i group
+ExecReload=/usr/sbin/nscd -i hosts
+ExecReload=/usr/sbin/nscd -i services
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/unscd/unscd-0.52-r1.ebuild b/sys-apps/unscd/unscd-0.52-r2.ebuild
index ad60b79b739b..c776e1362455 100644
--- a/sys-apps/unscd/unscd-0.52-r1.ebuild
+++ b/sys-apps/unscd/unscd-0.52-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/unscd/unscd-0.52-r1.ebuild,v 1.1 2014/10/09 13:43:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/unscd/unscd-0.52-r2.ebuild,v 1.1 2015/04/08 21:35:04 zmedico Exp $
EAPI=5
-inherit toolchain-funcs
+inherit systemd toolchain-funcs
DESCRIPTION="simple & stable nscd replacement"
HOMEPAGE="http://busybox.net/~vda/unscd/README"
@@ -31,5 +31,7 @@ src_compile() {
src_install() {
newinitd "${FILESDIR}"/unscd.initd-r1 unscd
+ systemd_newtmpfilesd "${FILESDIR}"/unscd-tmpfiles.conf unscd.conf
+ systemd_dounit "${FILESDIR}"/unscd.service
dosbin unscd
}