summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-04-05 12:20:23 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-04-05 12:20:23 +0000
commita21b84bfbd6cc3acd830fc5384860b4f44d8a478 (patch)
tree1793ddfb9f2e99c1901db9ba723e011457ccbb8a /sys-apps/tuxonice-userui
parentMultilib safe. (diff)
downloadgentoo-2-a21b84bfbd6cc3acd830fc5384860b4f44d8a478.tar.gz
gentoo-2-a21b84bfbd6cc3acd830fc5384860b4f44d8a478.tar.bz2
gentoo-2-a21b84bfbd6cc3acd830fc5384860b4f44d8a478.zip
Update patch for fbsplash compile.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/tuxonice-userui')
-rw-r--r--sys-apps/tuxonice-userui/ChangeLog6
-rw-r--r--sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch25
2 files changed, 27 insertions, 4 deletions
diff --git a/sys-apps/tuxonice-userui/ChangeLog b/sys-apps/tuxonice-userui/ChangeLog
index 824cc58b317f..a7e28d947aaf 100644
--- a/sys-apps/tuxonice-userui/ChangeLog
+++ b/sys-apps/tuxonice-userui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/tuxonice-userui
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/ChangeLog,v 1.12 2009/04/04 11:40:40 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/ChangeLog,v 1.13 2009/04/05 12:20:23 nelchael Exp $
+
+ 05 Apr 2009; Krzysiek Pawlik <nelchael@gentoo.org>
+ files/tuxonice-userui-1.0-Makefiles.patch:
+ Update patch for fbsplash compile.
*tuxonice-userui-1.0 (04 Apr 2009)
diff --git a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch
index eee62228b460..8cc315f92082 100644
--- a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch
+++ b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch
@@ -1,6 +1,7 @@
---- tuxonice-userui-1.0.vanilla/Makefile 2009-04-04 12:37:13.000000000 +0100
-+++ tuxonice-userui-1.0/Makefile 2009-04-04 12:37:54.000000000 +0100
-@@ -32,10 +32,10 @@
+diff -Nru tuxonice-userui-1.0.vanilla/Makefile tuxonice-userui-1.0/Makefile
+--- tuxonice-userui-1.0.vanilla/Makefile 2009-04-04 13:37:13.000000000 +0200
++++ tuxonice-userui-1.0/Makefile 2009-04-05 14:13:23.000000000 +0200
+@@ -32,15 +32,15 @@
all: $(TARGETS)
fbsplash:
@@ -13,6 +14,12 @@
tuxoniceui_text: $(CORE_OBJECTS) userui_text.o
$(CC) $(LDFLAGS) -static $^ -o $@
+
+-tuxoniceui_fbsplash: fbsplash $(CORE_OBJECTS) fbsplash/userui_fbsplash.o
++tuxoniceui_fbsplash: fbsplash $(CORE_OBJECTS)
+ $(CC) $(LDFLAGS) -static $(CORE_OBJECTS) fbsplash/userui_fbsplash.o -o $@ $(FBSPLASH_LIBS)
+
+ tuxoniceui_usplash: usplash $(CORE_OBJECTS) usplash/userui_usplash.o
@@ -48,8 +48,8 @@
clean:
@@ -24,3 +31,15 @@
$(INSTDIR)/%: %
strip $<
+diff -Nru tuxonice-userui-1.0.vanilla/fbsplash/Makefile tuxonice-userui-1.0/fbsplash/Makefile
+--- tuxonice-userui-1.0.vanilla/fbsplash/Makefile 2009-04-04 13:37:13.000000000 +0200
++++ tuxonice-userui-1.0/fbsplash/Makefile 2009-04-05 14:14:53.000000000 +0200
+@@ -6,7 +6,7 @@
+ parse.o mng_callbacks.o mng_render.o render.o ttf.o
+ SOURCES = $(patsubst %.o,%.c,$(OBJECTS))
+
+-all: $(TARGET)
++all: $(TARGET) $(OBJECTS)
+
+ userui_fbsplash.o: $(OBJECTS)
+ $(CC) $(LDFLAGS) -r -nostdlib -nostartfiles $(SPLASH_LDLIBS) $^ -o $@