summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-28 08:28:49 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-28 08:28:49 +0000
commit4602b4042a7aec2bf5780d2aa5674bd35d63d3e6 (patch)
tree1555eba39869cddade739d35f4cdf0e68e1cfe42 /sys-apps/tuxonice-userui
parentadd patch to fix compilation error with Ruby 1.9 wrt bug #439622 (diff)
downloadgentoo-2-4602b4042a7aec2bf5780d2aa5674bd35d63d3e6.tar.gz
gentoo-2-4602b4042a7aec2bf5780d2aa5674bd35d63d3e6.tar.bz2
gentoo-2-4602b4042a7aec2bf5780d2aa5674bd35d63d3e6.zip
Compile fbsplash support properly and add migration information for people upgrading from 1.0, bug #439120 by Sergey Fionov.
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-apps/tuxonice-userui')
-rw-r--r--sys-apps/tuxonice-userui/ChangeLog9
-rw-r--r--sys-apps/tuxonice-userui/tuxonice-userui-1.1-r1.ebuild (renamed from sys-apps/tuxonice-userui/tuxonice-userui-1.1.ebuild)16
2 files changed, 16 insertions, 9 deletions
diff --git a/sys-apps/tuxonice-userui/ChangeLog b/sys-apps/tuxonice-userui/ChangeLog
index bb42931dee89..d28b1941a8c6 100644
--- a/sys-apps/tuxonice-userui/ChangeLog
+++ b/sys-apps/tuxonice-userui/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/tuxonice-userui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/ChangeLog,v 1.25 2012/10/20 08:17:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/ChangeLog,v 1.26 2012/10/28 08:28:49 pacho Exp $
+
+*tuxonice-userui-1.1-r1 (28 Oct 2012)
+
+ 28 Oct 2012; Pacho Ramos <pacho@gentoo.org> +tuxonice-userui-1.1-r1.ebuild,
+ -tuxonice-userui-1.1.ebuild:
+ Compile fbsplash support properly and add migration information for people
+ upgrading from 1.0, bug #439120 by Sergey Fionov.
*tuxonice-userui-1.1 (20 Oct 2012)
diff --git a/sys-apps/tuxonice-userui/tuxonice-userui-1.1.ebuild b/sys-apps/tuxonice-userui/tuxonice-userui-1.1-r1.ebuild
index 7bd87ca6b626..cb8ffabae1c0 100644
--- a/sys-apps/tuxonice-userui/tuxonice-userui-1.1.ebuild
+++ b/sys-apps/tuxonice-userui/tuxonice-userui-1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/tuxonice-userui-1.1.ebuild,v 1.1 2012/10/20 08:17:47 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/tuxonice-userui-1.1-r1.ebuild,v 1.1 2012/10/28 08:28:49 pacho Exp $
EAPI=4
inherit toolchain-funcs eutils
@@ -35,13 +35,8 @@ src_compile() {
# Package contain binaries
emake clean
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- tuxoniceui || die "emake tuxoniceui_text failed"
-
- if use fbsplash; then
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- fbsplash || die "emake tuxoniceui_fbsplash failed"
- fi
+ emake CC="$(tc-getCC)" USE_FBSPLASH=$(use fbsplash && echo 1 || echo 0) \
+ tuxoniceui || die "emake tuxoniceui failed"
}
src_install() {
@@ -57,6 +52,11 @@ pkg_postinst() {
elog "to the theme you want tuxonice to use, e.g.:"
elog
elog " # ln -sfn /etc/splash/emergence /etc/splash/tuxonice"
+ if [[ ${REPLACING_VERSIONS} < 1.1 ]]; then
+ einfo
+ elog "You must replace '/sbin/tuxoniceui_fbsplash' with '/sbin/tuxoniceui -f'"
+ elog "in kernel config."
+ fi
fi
einfo
einfo "Please see /usr/share/doc/${PF}/README.* for further"