summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-01-08 20:11:26 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-01-08 20:11:26 +0000
commit6d2a51604806d98962a6928ed63de3425c6c94e2 (patch)
treebe64f0c063faa73d60e4f46506eb6cb97cb0ff04 /sys-apps/tuxonice-userui/tuxonice-userui-0.7.3.ebuild
parentRemoving old (diff)
downloadgentoo-2-6d2a51604806d98962a6928ed63de3425c6c94e2.tar.gz
gentoo-2-6d2a51604806d98962a6928ed63de3425c6c94e2.tar.bz2
gentoo-2-6d2a51604806d98962a6928ed63de3425c6c94e2.zip
Version bump, dropped fbsplash patch for now.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'sys-apps/tuxonice-userui/tuxonice-userui-0.7.3.ebuild')
-rw-r--r--sys-apps/tuxonice-userui/tuxonice-userui-0.7.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/tuxonice-userui/tuxonice-userui-0.7.3.ebuild b/sys-apps/tuxonice-userui/tuxonice-userui-0.7.3.ebuild
new file mode 100644
index 000000000000..62b1cbaa21c0
--- /dev/null
+++ b/sys-apps/tuxonice-userui/tuxonice-userui-0.7.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tuxonice-userui/tuxonice-userui-0.7.3.ebuild,v 1.1 2009/01/08 20:11:26 nelchael Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="User Interface for TuxOnIce"
+HOMEPAGE="http://www.tuxonice.net"
+SRC_URI="http://www.tuxonice.net/downloads/all/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ # Package contain binaries
+ emake clean
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ tuxoniceui_text || die "emake tuxoniceui_text failed"
+}
+
+src_install() {
+ into /
+ dosbin tuxoniceui_text
+ dodoc AUTHORS ChangeLog KERNEL_API README TODO USERUI_API
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please see /usr/share/doc/${PF}/README.* for further"
+ einfo "instructions."
+ einfo
+}