summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-05-25 20:45:14 +0000
committerJeroen Roovers <jer@gentoo.org>2008-05-25 20:45:14 +0000
commit98cab7df086b1ec33c5fa823012a74a3c916b6e8 (patch)
tree2127abde721dfe9c3f290b2e7b8a1cb49adf2f37 /sys-apps/turbotail
parentVersion bump (diff)
downloadgentoo-2-98cab7df086b1ec33c5fa823012a74a3c916b6e8.tar.gz
gentoo-2-98cab7df086b1ec33c5fa823012a74a3c916b6e8.tar.bz2
gentoo-2-98cab7df086b1ec33c5fa823012a74a3c916b6e8.zip
Add DNOTIFY support.
(Portage version: 2.1.5)
Diffstat (limited to 'sys-apps/turbotail')
-rw-r--r--sys-apps/turbotail/ChangeLog5
-rw-r--r--sys-apps/turbotail/turbotail-0.3.ebuild14
2 files changed, 15 insertions, 4 deletions
diff --git a/sys-apps/turbotail/ChangeLog b/sys-apps/turbotail/ChangeLog
index 028c50ec49cd..0d672e7b2a64 100644
--- a/sys-apps/turbotail/ChangeLog
+++ b/sys-apps/turbotail/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/turbotail
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/ChangeLog,v 1.7 2008/05/25 20:31:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/ChangeLog,v 1.8 2008/05/25 20:45:14 jer Exp $
+
+ 25 May 2008; Jeroen Roovers <jer@gentoo.org> turbotail-0.3.ebuild:
+ Add DNOTIFY support.
*turbotail-0.3 (25 May 2008)
diff --git a/sys-apps/turbotail/turbotail-0.3.ebuild b/sys-apps/turbotail/turbotail-0.3.ebuild
index a0cf8277c68a..05a58be30a56 100644
--- a/sys-apps/turbotail/turbotail-0.3.ebuild
+++ b/sys-apps/turbotail/turbotail-0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/turbotail-0.3.ebuild,v 1.1 2008/05/25 20:31:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/turbotail-0.3.ebuild,v 1.2 2008/05/25 20:45:14 jer Exp $
inherit toolchain-funcs
@@ -11,12 +11,20 @@ SRC_URI="http://www.vanheusden.com/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86"
-IUSE=""
+IUSE="fam"
DEPEND="app-admin/gamin"
src_compile() {
- $(tc-getCC) -DVERSION=\"${PV}\" ${PN}.c -o ${PN} || die "compile failed"
+ local myconf
+ if use fam; then
+ myconf="-DUSE_FAM -lfam"
+ else
+ myconf="-DUSE_DNOTIFY"
+ fi
+
+ $(tc-getCC) ${myconf} -DVERSION=\"${PV}\" ${PN}.c -o ${PN} \
+ || die "compile failed"
}
src_install() {