summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2005-08-05 19:55:27 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2005-08-05 19:55:27 +0000
commit4ce7335889a4afcdf3db78a7927abac01e2d9b2f (patch)
tree73c62c2e7fc5a2326270a5451cf23f7434b9fabd /sys-apps/turbotail
parentFixed inheritence structure. 10.3 and 10.4 are now nicely split. (diff)
downloadgentoo-2-4ce7335889a4afcdf3db78a7927abac01e2d9b2f.tar.gz
gentoo-2-4ce7335889a4afcdf3db78a7927abac01e2d9b2f.tar.bz2
gentoo-2-4ce7335889a4afcdf3db78a7927abac01e2d9b2f.zip
initial commit. see bug #71933.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/turbotail')
-rw-r--r--sys-apps/turbotail/ChangeLog10
-rw-r--r--sys-apps/turbotail/Manifest3
-rw-r--r--sys-apps/turbotail/files/digest-turbotail-0.21
-rw-r--r--sys-apps/turbotail/metadata.xml5
-rw-r--r--sys-apps/turbotail/turbotail-0.2.ebuild25
5 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/turbotail/ChangeLog b/sys-apps/turbotail/ChangeLog
new file mode 100644
index 000000000000..8e40b904ed98
--- /dev/null
+++ b/sys-apps/turbotail/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-apps/turbotail
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/ChangeLog,v 1.1 2005/08/05 19:55:26 sbriesen Exp $
+
+*turbotail-0.2 (05 Aug 2005)
+
+ 05 Aug 2005; Stefan Briesenick <sbriesen@gentoo.org> +metadata.xml,
+ +turbotail-0.2.ebuild:
+ initial commit. see bug #71933.
+
diff --git a/sys-apps/turbotail/Manifest b/sys-apps/turbotail/Manifest
new file mode 100644
index 000000000000..4611f25d4ae2
--- /dev/null
+++ b/sys-apps/turbotail/Manifest
@@ -0,0 +1,3 @@
+MD5 1bb07a806db3066f70b38077acaf01e6 turbotail-0.2.ebuild 576
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 92a0255cbb3e1575323119175be61a46 files/digest-turbotail-0.2 60
diff --git a/sys-apps/turbotail/files/digest-turbotail-0.2 b/sys-apps/turbotail/files/digest-turbotail-0.2
new file mode 100644
index 000000000000..45c55b7c1488
--- /dev/null
+++ b/sys-apps/turbotail/files/digest-turbotail-0.2
@@ -0,0 +1 @@
+MD5 24903c65622391e62f238218cfc5c2d7 turbotail-0.2.tgz 6411
diff --git a/sys-apps/turbotail/metadata.xml b/sys-apps/turbotail/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/turbotail/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>
diff --git a/sys-apps/turbotail/turbotail-0.2.ebuild b/sys-apps/turbotail/turbotail-0.2.ebuild
new file mode 100644
index 000000000000..48a507f6790d
--- /dev/null
+++ b/sys-apps/turbotail/turbotail-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/turbotail/turbotail-0.2.ebuild,v 1.1 2005/08/05 19:55:26 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="drop-in replacement for 'tail' which uses the kernel DNOTIFY-api"
+HOMEPAGE="http://www.vanheusden.com/Linux/"
+SRC_URI="http://www.vanheusden.com/Linux/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ # enforce our CFLAGS
+ emake CFLAGS="-Wall ${CFLAGS} -DVERSION=\"${VERSION}\"" || die "emake failed"
+}
+
+src_install() {
+ dobin turbotail || die "install failed"
+ dodoc readme.txt
+}