summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-11 07:04:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-11 07:04:05 +0000
commit533b701f2f7de77a2c1af44de7244d2b40face43 (patch)
tree794716d7263ef1ad0df01fca0b4683e42bcd4193 /sys-apps/time
parentNew portage ebuild! Maybe this one works, eh? Virtuals fix. (Manifest recommit) (diff)
downloadgentoo-2-533b701f2f7de77a2c1af44de7244d2b40face43.tar.gz
gentoo-2-533b701f2f7de77a2c1af44de7244d2b40face43.tar.bz2
gentoo-2-533b701f2f7de77a2c1af44de7244d2b40face43.zip
clean up
Diffstat (limited to 'sys-apps/time')
-rw-r--r--sys-apps/time/ChangeLog6
-rw-r--r--sys-apps/time/files/1.7-info-dir-entry.patch12
-rw-r--r--sys-apps/time/files/digest-time-1.71
-rw-r--r--sys-apps/time/time-1.7-r1.ebuild38
-rw-r--r--sys-apps/time/time-1.7.ebuild25
5 files changed, 34 insertions, 48 deletions
diff --git a/sys-apps/time/ChangeLog b/sys-apps/time/ChangeLog
index f30b06e1d177..5db31eb4a886 100644
--- a/sys-apps/time/ChangeLog
+++ b/sys-apps/time/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/time
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/time/ChangeLog,v 1.11 2004/07/29 01:40:39 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/time/ChangeLog,v 1.12 2004/09/11 07:04:05 vapier Exp $
+
+ 11 Sep 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.7-info-dir-entry.patch, time-1.7-r1.ebuild, -time-1.7.ebuild:
+ Redo the whole ebuild ... much cleaner this way says i.
28 Jul 2004; Tom Gall <tgall@gentoo.org> time-1.7-r1.ebuild:
stable on ppc64, bug #58303
diff --git a/sys-apps/time/files/1.7-info-dir-entry.patch b/sys-apps/time/files/1.7-info-dir-entry.patch
new file mode 100644
index 000000000000..1cc057b04ea1
--- /dev/null
+++ b/sys-apps/time/files/1.7-info-dir-entry.patch
@@ -0,0 +1,12 @@
+--- time.info.old 2004-09-11 03:00:39.076871344 -0400
++++ time.info 2004-09-11 03:00:40.394671008 -0400
+@@ -19,6 +19,9 @@
+ manual into another language, under the above conditions for modified
+ versions, except that this permission notice may be stated in a
+ translation approved by the Foundation.
++START-INFO-DIR-ENTRY
++* time: (time). summarize system resources used
++END-INFO-DIR-ENTRY
+
+ 
+ File: time.info, Node: Top, Prev: (dir), Up: (dir)
diff --git a/sys-apps/time/files/digest-time-1.7 b/sys-apps/time/files/digest-time-1.7
deleted file mode 100644
index 62b151f40451..000000000000
--- a/sys-apps/time/files/digest-time-1.7
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e38d2b8b34b1ca259cf7b053caac32b3 time-1.7.tar.gz 103066
diff --git a/sys-apps/time/time-1.7-r1.ebuild b/sys-apps/time/time-1.7-r1.ebuild
index 227df0b73d10..80e1ed7e8f2c 100644
--- a/sys-apps/time/time-1.7-r1.ebuild
+++ b/sys-apps/time/time-1.7-r1.ebuild
@@ -1,33 +1,29 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/time/time-1.7-r1.ebuild,v 1.18 2004/07/29 01:40:39 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/time/time-1.7-r1.ebuild,v 1.19 2004/09/11 07:04:05 vapier Exp $
-DESCRIPTION="A command that displays info about resources used by a program"
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/time/${P}.tar.gz"
+inherit eutils
+
+DESCRIPTION="displays info about resources used by a program"
HOMEPAGE="http://www.gnu.org/directory/time.html"
-KEYWORDS="x86 amd64 ppc sparc ppc64"
-IUSE=""
-SLOT="0"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/time/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 sparc x86"
+IUSE=""
DEPEND="virtual/libc"
-src_compile() {
- ./configure --prefix=/usr \
- --mandir=/usr/share/man || die
- emake || die
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ automake -a || die "automake"
+ autoconf || die "autoconf"
+ epatch ${FILESDIR}/${PV}-info-dir-entry.patch
}
src_install() {
- cd ${S}
- echo "START-INFO-DIR-ENTRY
-* time: (time). summarize system resources used
-END-INFO-DIR-ENTRY" > temp
- sed -e '/^trans/r temp' < time.info > time.info.new
- mv time.info.new time.info
-
- make prefix=${D}/usr sysconfdir=${D}/etc mandir=${D}/usr/share/man install || die
- gzip -9 ${D}/usr/info/time.info
- dodoc ChangeLog COPYING README
- dodoc AUTHORS NEWS
+ make install DESTDIR=${D} || die
+ dodoc ChangeLog README AUTHORS NEWS
}
diff --git a/sys-apps/time/time-1.7.ebuild b/sys-apps/time/time-1.7.ebuild
deleted file mode 100644
index 333da7fb140e..000000000000
--- a/sys-apps/time/time-1.7.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/time/time-1.7.ebuild,v 1.10 2004/07/15 02:41:35 agriffis Exp $
-
-DESCRIPTION="A command that displays info about resources used by a program"
-SRC_URI="ftp://ftp.gnu.org/pub/gnu/time/${P}.tar.gz"
-HOMEPAGE="http://www.gnu.org/directory/time.html"
-KEYWORDS="x86 amd64"
-IUSE=""
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND="virtual/libc"
-
-src_compile() {
- ./configure --prefix=/usr \
- --mandir=/usr/share/man || die
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr sysconfdir=${D}/etc mandir=${D}/usr/share/man install || die
- dodoc ChangeLog COPYING README
- dodoc AUTHORS NEWS
-}