summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-07-01 06:39:14 +0000
committerTim Harder <radhermit@gentoo.org>2014-07-01 06:39:14 +0000
commit8ba543c713bdac93e3dd21c5e75e354ff4676cff (patch)
treec479473aab079f5382a316fb23331078b1419802 /sys-apps/the_silver_searcher
parentapp-editors/retext: Drop incompatibility workaround for USE=spell + python3_3 (diff)
downloadgentoo-2-8ba543c713bdac93e3dd21c5e75e354ff4676cff.tar.gz
gentoo-2-8ba543c713bdac93e3dd21c5e75e354ff4676cff.tar.bz2
gentoo-2-8ba543c713bdac93e3dd21c5e75e354ff4676cff.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/the_silver_searcher')
-rw-r--r--sys-apps/the_silver_searcher/ChangeLog8
-rw-r--r--sys-apps/the_silver_searcher/the_silver_searcher-0.23.0.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-apps/the_silver_searcher/ChangeLog b/sys-apps/the_silver_searcher/ChangeLog
index 33723ad19086..e8a7ccfa30af 100644
--- a/sys-apps/the_silver_searcher/ChangeLog
+++ b/sys-apps/the_silver_searcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/the_silver_searcher
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.38 2014/05/13 04:53:07 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/ChangeLog,v 1.39 2014/07/01 06:39:14 radhermit Exp $
+
+*the_silver_searcher-0.23.0 (01 Jul 2014)
+
+ 01 Jul 2014; Tim Harder <radhermit@gentoo.org>
+ +the_silver_searcher-0.23.0.ebuild:
+ Version bump.
*the_silver_searcher-0.22.0 (13 May 2014)
diff --git a/sys-apps/the_silver_searcher/the_silver_searcher-0.23.0.ebuild b/sys-apps/the_silver_searcher/the_silver_searcher-0.23.0.ebuild
new file mode 100644
index 000000000000..1cbd33ea36e6
--- /dev/null
+++ b/sys-apps/the_silver_searcher/the_silver_searcher-0.23.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/the_silver_searcher/the_silver_searcher-0.23.0.ebuild,v 1.1 2014/07/01 06:39:14 radhermit Exp $
+
+EAPI=5
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A code-searching tool similar to ack, but faster"
+HOMEPAGE="http://github.com/ggreer/the_silver_searcher"
+SRC_URI="https://github.com/ggreer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="lzma zlib"
+
+RDEPEND="dev-libs/libpcre
+ lzma? ( app-arch/xz-utils )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="README.md"
+
+src_prepare() {
+ sed -i '/^dist_bashcomp/d' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lzma) \
+ $(use_enable zlib)
+}
+
+src_install() {
+ default
+ newbashcomp ag.bashcomp.sh ag
+}