summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-02-19 23:41:00 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-02-19 23:41:00 +0000
commita7816f6df99d470df73799e4049863614caa6a4a (patch)
tree9a6042a908838f5b9739850d15938b1396cf2769 /sys-apps/texinfo
parentfix bug #15817 .. borking when CC not set (diff)
downloadgentoo-2-a7816f6df99d470df73799e4049863614caa6a4a.tar.gz
gentoo-2-a7816f6df99d470df73799e4049863614caa6a4a.tar.bz2
gentoo-2-a7816f6df99d470df73799e4049863614caa6a4a.zip
new version
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/ChangeLog7
-rw-r--r--sys-apps/texinfo/files/digest-texinfo-4.51
-rw-r--r--sys-apps/texinfo/texinfo-4.5.ebuild74
3 files changed, 81 insertions, 1 deletions
diff --git a/sys-apps/texinfo/ChangeLog b/sys-apps/texinfo/ChangeLog
index 9a645973bdb3..249b60da7068 100644
--- a/sys-apps/texinfo/ChangeLog
+++ b/sys-apps/texinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/texinfo
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.21 2003/02/15 20:19:52 tuxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.22 2003/02/19 23:41:00 azarah Exp $
+
+*texinfo-4.5 (19 Feb 2003)
+
+ 19 Feb 2003; Martin Schlemmer <azarah@gentoo.org texinfo-4.5.ebuild :
+ Update version, closing bug #15075.
15 Feb 2003; Jan Seidel <tuxus@gentoo.org> texinfo-4.3.ebuild :
Added mips to keywords
diff --git a/sys-apps/texinfo/files/digest-texinfo-4.5 b/sys-apps/texinfo/files/digest-texinfo-4.5
new file mode 100644
index 000000000000..75daa59c5c1a
--- /dev/null
+++ b/sys-apps/texinfo/files/digest-texinfo-4.5
@@ -0,0 +1 @@
+MD5 8a5d6b54bc2ff5ec51c696a4e89d93b2 texinfo-4.5.tar.gz 1809075
diff --git a/sys-apps/texinfo/texinfo-4.5.ebuild b/sys-apps/texinfo/texinfo-4.5.ebuild
new file mode 100644
index 000000000000..2393f20f0ea4
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.5.ebuild,v 1.1 2003/02/19 23:41:00 azarah Exp $
+
+IUSE="nls build"
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="The GNU info program and utilities"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/texinfo/${P}.tar.gz
+ ftp://alpha.gnu.org/pub/gnu/texinfo/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/texinfo/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha ~hppa"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ !build? ( >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext ) )"
+RDEPEND="virtual/glibc
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/doc
+ # Get the texinfo info page to have a proper name of texinfo.info
+ cp texinfo.txi texinfo.txi.orig
+ sed -e 's:setfilename texinfo:setfilename texinfo.info:' \
+ texinfo.txi.orig > texinfo.txi
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:INFO_DEPS = texinfo:INFO_DEPS = texinfo.info:' \
+ -e 's:texinfo\::texinfo.info\::' \
+ Makefile.in.orig > Makefile.in
+}
+
+src_compile() {
+ local myconf=
+ if [ -z "`use nls`" ] || [ -n "`use build`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ export WANT_AUTOMAKE_1_6=1
+ econf ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ if [ -n "`use build`" ] ; then
+ mv util/ginstall-info util/install-info
+ dobin makeinfo/makeinfo util/{install-info,texi2dvi,texindex}
+ else
+ make DESTDIR=${D} \
+ infodir=/usr/share/info \
+ install || die
+
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/mkinfodir
+
+ if [ ! -f ${D}/usr/share/info/texinfo.info ] ; then
+ die "Could not install texinfo.info!!!"
+ fi
+
+ dodoc AUTHORS ChangeLog COPYING INTRODUCTION NEWS README TODO
+ docinto info
+ dodoc info/README
+ docinto makeinfo
+ dodoc makeinfo/README
+ fi
+}
+