summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 15:55:15 +0000
commit36d7d63fc8e533a54bc3008fe078d25b06cc0d55 (patch)
treebbf6a3f305a5e307e2b8b191680365bd8b5a23b2 /sys-apps/tcp-wrappers
parent*** empty log message *** (diff)
downloadgentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.gz
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.tar.bz2
gentoo-2-36d7d63fc8e533a54bc3008fe078d25b06cc0d55.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-apps/tcp-wrappers')
-rw-r--r--sys-apps/tcp-wrappers/files/tcp_wrappers_7.6-ipv6-1.6.diff.gzbin0 -> 8385 bytes
-rw-r--r--sys-apps/tcp-wrappers/files/tcp_wrappers_7.6.dif185
-rw-r--r--sys-apps/tcp-wrappers/tcp-wrappers-7.6-r2.ebuild46
3 files changed, 231 insertions, 0 deletions
diff --git a/sys-apps/tcp-wrappers/files/tcp_wrappers_7.6-ipv6-1.6.diff.gz b/sys-apps/tcp-wrappers/files/tcp_wrappers_7.6-ipv6-1.6.diff.gz
new file mode 100644
index 000000000000..55c348c41ef4
--- /dev/null
+++ b/sys-apps/tcp-wrappers/files/tcp_wrappers_7.6-ipv6-1.6.diff.gz
Binary files differ
diff --git a/sys-apps/tcp-wrappers/files/tcp_wrappers_7.6.dif b/sys-apps/tcp-wrappers/files/tcp_wrappers_7.6.dif
new file mode 100644
index 000000000000..a3b9f1df3713
--- /dev/null
+++ b/sys-apps/tcp-wrappers/files/tcp_wrappers_7.6.dif
@@ -0,0 +1,185 @@
+--- hosts_access.c
++++ hosts_access.c 2000/01/21 16:06:56
+@@ -33,6 +33,7 @@
+ #include <errno.h>
+ #include <setjmp.h>
+ #include <string.h>
++#include <rpcsvc/ypclnt.h>
+
+ extern char *fgets();
+ extern int errno;
+@@ -88,6 +89,33 @@
+ #define BUFLEN 2048
+
+ /* hosts_access - host access control facility */
++
++int
++yp_get_default_domain (char **outdomain)
++{
++ static char __ypdomainname[1025] = "\0";
++ int result = YPERR_SUCCESS;;
++ *outdomain = NULL;
++
++ if (__ypdomainname[0] == '\0')
++ {
++ if (getdomainname (__ypdomainname, 1024))
++ result = YPERR_NODOM;
++ else if (strcmp (__ypdomainname, "(none)") == 0)
++ {
++ /* If domainname is not set, some Systems will return "(none)" */
++ __ypdomainname[0] = '\0';
++ result = YPERR_NODOM;
++ }
++ else
++ *outdomain = __ypdomainname;
++ }
++ else
++ *outdomain = __ypdomainname;
++
++ return result;
++}
++
+
+ int hosts_access(request)
+ struct request_info *request;
+--- Makefile
++++ Makefile 2000/01/21 16:45:52
+@@ -44,7 +44,7 @@
+ #REAL_DAEMON_DIR=/usr/etc
+ #
+ # SysV.4 Solaris 2.x OSF AIX
+-#REAL_DAEMON_DIR=/usr/sbin
++REAL_DAEMON_DIR=/usr/sbin
+ #
+ # BSD 4.4
+ #REAL_DAEMON_DIR=/usr/libexec
+@@ -143,8 +143,9 @@
+
+ linux:
+ @make REAL_DAEMON_DIR=$(REAL_DAEMON_DIR) STYLE=$(STYLE) \
+- LIBS= RANLIB=ranlib ARFLAGS=rv AUX_OBJ=setenv.o \
+- NETGROUP= TLI= EXTRA_CFLAGS="-DBROKEN_SO_LINGER" all
++ LIBS= RANLIB=ranlib ARFLAGS=rv AUX_OBJ= \
++ NETGROUP=-DNETGROUP TLI= \
++ EXTRA_CFLAGS="-DSYS_ERRLIST_DEFINED -DINET6=1 -Dss_family=__ss_family" all
+
+ # This is good for many SYSV+BSD hybrids with NIS, probably also for HP-UX 7.x.
+ hpux hpux8 hpux9 hpux10:
+@@ -229,7 +230,7 @@
+
+ # Amdahl UTS 2.1.5 (Richard.Richmond@bridge.bst.bls.com)
+ uts215:
+- @make REAL_DAEMON_DIR=$(REAL_DAEMON_DIR) STYLE=$(STYLE) \
++ @make REAL_DAEMON_DIR=$(REAL_DAEMON_DIR) STYLE=$(STYLE) \
+ LIBS="-lsocket" RANLIB=echo \
+ ARFLAGS=rv AUX_OBJ=setenv.o NETGROUP=-DNO_NETGROUP TLI= all
+
+@@ -472,7 +473,7 @@
+ # If your system supports vsyslog(), comment out the following definition.
+ # If in doubt leave it in, it won't harm.
+
+-VSYSLOG = -Dvsyslog=myvsyslog
++#VSYSLOG = -Dvsyslog=myvsyslog
+
+ # End of the system dependencies.
+ #################################
+@@ -491,7 +492,7 @@
+ # Uncomment the next definition to turn on the language extensions
+ # (examples: allow, deny, banners, twist and spawn).
+ #
+-#STYLE = -DPROCESS_OPTIONS # Enable language extensions.
++STYLE = -DPROCESS_OPTIONS # Enable language extensions.
+
+ ################################################################
+ # Optional: Changing the default disposition of logfile records
+@@ -514,7 +515,7 @@
+ #
+ # The LOG_XXX names below are taken from the /usr/include/syslog.h file.
+
+-FACILITY= LOG_MAIL # LOG_MAIL is what most sendmail daemons use
++FACILITY= LOG_AUTHPRIV # LOG_MAIL is what most sendmail daemons use
+
+ # The syslog priority at which successful connections are logged.
+
+@@ -531,7 +532,7 @@
+ # and with Solaris < 2.4. APPEND_DOT will not work with hostnames taken
+ # from /etc/hosts or from NIS maps. It does work with DNS through NIS.
+ #
+-# DOT= -DAPPEND_DOT
++DOT= -DAPPEND_DOT
+
+ ##################################################
+ # Optional: Always attempt remote username lookups
+@@ -551,7 +552,7 @@
+ # still do selective username lookups as documented in the hosts_access.5
+ # and hosts_options.5 manual pages (`nroff -man' format).
+ #
+-#AUTH = -DALWAYS_RFC931
++AUTH = -DALWAYS_RFC931
+ #
+ # The default username lookup timeout is 10 seconds. This may not be long
+ # enough for slow hosts or networks, but is enough to irritate PC users.
+@@ -610,7 +611,7 @@
+ # Paranoid mode implies hostname lookup. In order to disable hostname
+ # lookups altogether, see the next section.
+
+-PARANOID= -DPARANOID
++#PARANOID= -DPARANOID
+
+ ########################################
+ # Optional: turning off hostname lookups
+@@ -649,7 +650,7 @@
+ # source-routed traffic in the kernel. Examples: 4.4BSD derivatives,
+ # Solaris 2.x, and Linux. See your system documentation for details.
+ #
+-# KILL_OPT= -DKILL_IP_OPTIONS
++#KILL_OPT= -DKILL_IP_OPTIONS
+
+ ## End configuration options
+ ############################
+@@ -659,12 +660,12 @@
+ SHELL = /bin/sh
+ .c.o:; $(CC) $(CFLAGS) -c $*.c
+
+-CFLAGS = -O -DFACILITY=$(FACILITY) $(ACCESS) $(PARANOID) $(NETGROUP) \
++CFLAGS = -O2 -pipe -DFACILITY=$(FACILITY) $(ACCESS) $(PARANOID) $(NETGROUP) \
+ $(BUGS) $(SYSTYPE) $(AUTH) $(UMASK) \
+ -DREAL_DAEMON_DIR=\"$(REAL_DAEMON_DIR)\" $(STYLE) $(KILL_OPT) \
+ -DSEVERITY=$(SEVERITY) -DRFC931_TIMEOUT=$(RFC931_TIMEOUT) \
+ $(UCHAR) $(TABLES) $(STRINGS) $(TLI) $(EXTRA_CFLAGS) $(DOT) \
+- $(VSYSLOG) $(HOSTNAME)
++ $(VSYSLOG)
+
+ LIB_OBJ= hosts_access.o options.o shell_cmd.o rfc931.o eval.o \
+ hosts_ctl.o refuse.o percent_x.o clean_exit.o $(AUX_OBJ) \
+--- README.ipv6
++++ README.ipv6 2000/01/21 15:52:43
+@@ -0,0 +1,17 @@
++;; IPv6 patch for tcp_wrappers_7.6 1.6
++;; Aug 23, 1999 by Hajimu UMEMOTO <ume@mahoroba.org>
++;;
++;; This patch supports IPv4/IPv6 dual stack and IPv4-mapped IPv6 address.
++;; You can replace stock tcpd or libwrap.a with this.
++;; IPv6 address pattern is as a `[net]/prefixlen' pair.
++;; This patch was tested on KAME/FreeBSD, KAME/FreeBSD3, KAME/NetBSD,
++;; RedHat 5.1 with kernel 2.1.126, and RedHat 6.0 with kernel 2.2.10.
++;;
++;; CAUTION:
++;; Back out change for field separater. Now, field separater is `:'
++;; not `|'. To specify IPv6 address, enclose IPv6 address with `['
++;; and `]'.
++;;
++;; For Linux users:
++;; If your libc doesn't have sockaddr_storage, try target `linux-old'.
++
+--- safe_finger.c
++++ safe_finger.c 2000/01/21 16:06:56
+@@ -31,7 +31,7 @@
+
+ /* Local stuff */
+
+-char path[] = "PATH=/bin:/usr/bin:/usr/ucb:/usr/bsd:/etc:/usr/etc:/usr/sbin";
++char path[] = "PATH=/bin:/usr/bin:/usr/sbin";
+
+ #define TIME_LIMIT 60 /* Do not keep listinging forever */
+ #define INPUT_LENGTH 100000 /* Do not keep listinging forever */
diff --git a/sys-apps/tcp-wrappers/tcp-wrappers-7.6-r2.ebuild b/sys-apps/tcp-wrappers/tcp-wrappers-7.6-r2.ebuild
new file mode 100644
index 000000000000..f86fe5f095dd
--- /dev/null
+++ b/sys-apps/tcp-wrappers/tcp-wrappers-7.6-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tcp-wrappers/tcp-wrappers-7.6-r2.ebuild,v 1.1 2001/02/07 15:51:28 achim Exp $
+
+A=tcp_wrappers_${PV}.tar.gz
+A0="tcp_wrappers_${PV}.dif"
+A1="tcp_wrappers_${PV}-ipv6-1.6.diff.gz"
+
+S=${WORKDIR}/tcp_wrappers_${PV}
+DESCRIPTION="tcp wrappers"
+SRC_URI="ftp://ftp.porcupine.org/pub/security/${A}"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}/
+ patch -p0 < ${FILESDIR}/${A0}
+ gzip -dc ${FILESDIR}/${A1} | patch -p2
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" \
+ -e "s:AUX_OBJ=.*:AUX_OBJ= \\\:" Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ try make ${MAKEOPTS} REAL_DAEMON_DIR=/usr/sbin linux
+}
+
+src_install() {
+
+ dosbin tcpd tcpdchk tcpdmatch safe_finger try-from
+ doman *.[358]
+ dolib.a libwrap.a
+ insinto /usr/include
+ doins tcpd.h
+
+ dodoc BLURB CHANGES DISCLAIMER README*
+}
+
+
+
+
+