summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-18 08:55:36 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-18 08:55:36 +0000
commit4e9ed63c121b4c1197a0feed2e3d3682a74f1d37 (patch)
tree8c500360c41219bec3bb260cabab813a09afd25e /sys-apps/sysvinit
parentold (diff)
downloadgentoo-2-4e9ed63c121b4c1197a0feed2e3d3682a74f1d37.tar.gz
gentoo-2-4e9ed63c121b4c1197a0feed2e3d3682a74f1d37.tar.bz2
gentoo-2-4e9ed63c121b4c1197a0feed2e3d3682a74f1d37.zip
Version bump #289502 by Peter Alfredsen.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/sysvinit')
-rw-r--r--sys-apps/sysvinit/ChangeLog9
-rw-r--r--sys-apps/sysvinit/sysvinit-2.87.ebuild83
2 files changed, 90 insertions, 2 deletions
diff --git a/sys-apps/sysvinit/ChangeLog b/sys-apps/sysvinit/ChangeLog
index 0ab76c7c2c49..9bd5f86a512c 100644
--- a/sys-apps/sysvinit/ChangeLog
+++ b/sys-apps/sysvinit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sysvinit
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.63 2008/12/18 20:26:27 robbat2 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/ChangeLog,v 1.64 2009/10/18 08:55:36 vapier Exp $
+
+*sysvinit-2.87 (18 Oct 2009)
+
+ 18 Oct 2009; Mike Frysinger <vapier@gentoo.org> +sysvinit-2.87.ebuild:
+ Version bump #289502 by Peter Alfredsen.
18 Dec 2008; Robin H. Johnson <robbat2@gentoo.org> files/inittab-2.86-r12:
Missed a comment.
diff --git a/sys-apps/sysvinit/sysvinit-2.87.ebuild b/sys-apps/sysvinit/sysvinit-2.87.ebuild
new file mode 100644
index 000000000000..2ca96342d5eb
--- /dev/null
+++ b/sys-apps/sysvinit/sysvinit-2.87.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.87.ebuild,v 1.1 2009/10/18 08:55:36 vapier Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+PATCH_VER="1"
+DESCRIPTION="/sbin/init - parent of all processes"
+HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
+SRC_URI="mirror://debian/pool/main/s/sysvinit/${PN}_${PV}dsf.orig.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+F="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
+ ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz
+ http://www.gc-linux.org/down/isobel/kexec/sysvinit/sysvinit-2.86-kexec.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux ibm static kernel_FreeBSD"
+
+RDEPEND="selinux? ( >=sys-libs/libselinux-1.28 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+S=${WORKDIR}/${P}dsf
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patches
+ sed -i '/^STRIP/s|=.*|=:|' src/Makefile
+
+ # Mung inittab for specific architectures
+ cd "${WORKDIR}"
+ cp "${FILESDIR}"/inittab-2.86-r12 inittab || die "cp inittab"
+ local insert=""
+ use ppc && insert='#psc0:12345:respawn:/sbin/agetty 115200 ttyPSC0 linux'
+ use arm && insert='#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100'
+ use hppa && insert='b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100'
+ use s390 && insert='s0:12345:respawn:/sbin/agetty 38400 console'
+ if use ibm ; then
+ insert="${insert}#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0"$'\n'
+ insert="${insert}#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0"
+ fi
+ (use arm || use mips || use sh || use sparc) && sed -i '/ttyS0/s:#::' inittab
+ if use kernel_FreeBSD ; then
+ sed -i \
+ -e 's/linux/cons25/g' \
+ -e 's/ttyS0/cuaa0/g' \
+ -e 's/ttyS1/cuaa1/g' \
+ inittab #121786
+ fi
+ [[ -n ${insert} ]] && echo "# Architecture specific features"$'\n'"${insert}" >> inittab
+}
+
+src_compile() {
+ tc-export CC
+ use static && append-ldflags -static
+ emake -C src || die
+}
+
+src_install() {
+ emake -C src \
+ install \
+ ROOT="${D}" \
+ || die "make install"
+ dodoc README doc/*
+
+ insinto /etc
+ doins "${WORKDIR}"/inittab || die "inittab"
+
+ doinitd "${FILESDIR}"/{reboot,shutdown}.sh || die
+}
+
+pkg_postinst() {
+ # Reload init to fix unmounting problems of / on next reboot.
+ # This is really needed, as without the new version of init cause init
+ # not to quit properly on reboot, and causes a fsck of / on next reboot.
+ if [[ ${ROOT} == / ]] ; then
+ # Do not return an error if this fails
+ /sbin/telinit U &>/dev/null
+ fi
+}