summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-03-02 16:43:32 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-03-02 16:43:32 +0000
commitccf7c1c91277e78136ee78c9985239904c5e2629 (patch)
tree7e22a32218a02c4da1bee57d6e0261cbb8e9a2f1 /sys-apps/syslog-notify/syslog-notify-0.1.ebuild
parentVersion bump KDE 4.4.1 (diff)
downloadgentoo-2-ccf7c1c91277e78136ee78c9985239904c5e2629.tar.gz
gentoo-2-ccf7c1c91277e78136ee78c9985239904c5e2629.tar.bz2
gentoo-2-ccf7c1c91277e78136ee78c9985239904c5e2629.zip
Initial commit of syslog-notify application. Fixes bug #304159
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/syslog-notify/syslog-notify-0.1.ebuild')
-rw-r--r--sys-apps/syslog-notify/syslog-notify-0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/syslog-notify/syslog-notify-0.1.ebuild b/sys-apps/syslog-notify/syslog-notify-0.1.ebuild
new file mode 100644
index 000000000000..3c98fe7ac9ab
--- /dev/null
+++ b/sys-apps/syslog-notify/syslog-notify-0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/syslog-notify/syslog-notify-0.1.ebuild,v 1.1 2010/03/02 16:43:32 hwoarang Exp $
+
+EAPI="2"
+
+DESCRIPTION="Notifications for syslog entries via libnotify"
+HOMEPAGE="http://jtniehof.github.com/syslog-notify/"
+SRC_URI="http://cloud.github.com/downloads/jtniehof/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="x11-libs/libnotify"
+RDEPEND="${DEPEND}
+ app-admin/syslog-ng"
+
+src_install() {
+ dosbin src/syslog-notify || die "install failed"
+ ebegin "Creating /var/spool/syslog-notify FIFO"
+ dodir /var/spool/ || die "dodir failed"
+ mkfifo "${D}"var/spool/syslog-notify || die "mkfifo failed"
+ eend $?
+ dodoc AUTHORS INSTALL README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Add the following options on your"
+ elog "/etc/syslog-ng/syslog-ng.conf file:"
+ elog " # destination notify { pipe("/var/spool/syslog-notify"); };"
+ elog " # log { source(src); destination(notify);};"
+ elog "Remember to restart syslog-ng before starting syslog-notify."
+}