summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-01-22 10:46:02 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-01-22 10:46:02 +0000
commit33d809877dc6186fb82a3dec08fa1cd3b7edd387 (patch)
treeb9d27d15a3630c97f53fae522204f514d28e7cbd /sys-apps/suspend2-userui
parentstable x86, bug #163123 (diff)
downloadgentoo-2-33d809877dc6186fb82a3dec08fa1cd3b7edd387.tar.gz
gentoo-2-33d809877dc6186fb82a3dec08fa1cd3b7edd387.tar.bz2
gentoo-2-33d809877dc6186fb82a3dec08fa1cd3b7edd387.zip
Fix for glib-2.5 (again)
(Portage version: 2.1.2-r2)
Diffstat (limited to 'sys-apps/suspend2-userui')
-rw-r--r--sys-apps/suspend2-userui/ChangeLog9
-rw-r--r--sys-apps/suspend2-userui/files/digest-suspend2-userui-0.6.4-r23
-rw-r--r--sys-apps/suspend2-userui/files/suspend2-userui-0.6.4-syscall.patch23
-rw-r--r--sys-apps/suspend2-userui/suspend2-userui-0.6.4-r2.ebuild68
4 files changed, 102 insertions, 1 deletions
diff --git a/sys-apps/suspend2-userui/ChangeLog b/sys-apps/suspend2-userui/ChangeLog
index 478b6467b8af..7a7c0a9ba518 100644
--- a/sys-apps/suspend2-userui/ChangeLog
+++ b/sys-apps/suspend2-userui/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/suspend2-userui
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/suspend2-userui/ChangeLog,v 1.19 2007/01/09 10:10:29 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/suspend2-userui/ChangeLog,v 1.20 2007/01/22 10:46:02 alonbl Exp $
+
+*suspend2-userui-0.6.4-r2 (22 Jan 2007)
+
+ 22 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/suspend2-userui-0.6.4-syscall.patch,
+ +suspend2-userui-0.6.4-r2.ebuild:
+ Fix for glib-2.5 (again)
09 Jan 2007; Alon Bar-Lev <alonbl@gentoo.org>
-files/suspend2-userui-0.6.3-skewed-image.patch,
diff --git a/sys-apps/suspend2-userui/files/digest-suspend2-userui-0.6.4-r2 b/sys-apps/suspend2-userui/files/digest-suspend2-userui-0.6.4-r2
new file mode 100644
index 000000000000..b69cd4626edc
--- /dev/null
+++ b/sys-apps/suspend2-userui/files/digest-suspend2-userui-0.6.4-r2
@@ -0,0 +1,3 @@
+MD5 737427dd2eb076907674a4334735c2ef suspend2-userui-0.6.4.tar.gz 91817
+RMD160 1f00e32ae28d0d19666db106dc2f64ff9ce99de5 suspend2-userui-0.6.4.tar.gz 91817
+SHA256 5b9b74832073df26d74158306ce673d1765246a2b630a8b68cd8ef21cb79b076 suspend2-userui-0.6.4.tar.gz 91817
diff --git a/sys-apps/suspend2-userui/files/suspend2-userui-0.6.4-syscall.patch b/sys-apps/suspend2-userui/files/suspend2-userui-0.6.4-syscall.patch
new file mode 100644
index 000000000000..56593df648b4
--- /dev/null
+++ b/sys-apps/suspend2-userui/files/suspend2-userui-0.6.4-syscall.patch
@@ -0,0 +1,23 @@
+diff -ru suspend2-userui-0.6.4/userui.h suspend2-userui-0.6.4-new/userui.h
+--- suspend2-userui-0.6.4/userui.h 2006-06-07 03:25:12.000000000 +1000
++++ suspend2-userui-0.6.4-new/userui.h 2006-10-14 01:57:51.000000000 +1000
+@@ -1,7 +1,7 @@
+ #ifndef _USERUI_H_
+ #define _USERUI_H_
+
+-#include <linux/unistd.h>
++#include <sys/syscall.h>
+ #include <sys/types.h>
+ #include "suspend_userui.h"
+
+@@ -124,8 +124,7 @@
+ /*
+ * Work around random glibc bugs where getpid() caches an invalid pid.
+ */
+-#define __NR_xgetpid __NR_getpid
+-static inline _syscall0(pid_t, xgetpid);
++#define xgetpid() syscall(SYS_getpid)
+
+
+ #endif /* _USERUI_H_ */
+
diff --git a/sys-apps/suspend2-userui/suspend2-userui-0.6.4-r2.ebuild b/sys-apps/suspend2-userui/suspend2-userui-0.6.4-r2.ebuild
new file mode 100644
index 000000000000..a440c888d5fd
--- /dev/null
+++ b/sys-apps/suspend2-userui/suspend2-userui-0.6.4-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/suspend2-userui/suspend2-userui-0.6.4-r2.ebuild,v 1.1 2007/01/22 10:46:02 alonbl Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="User Interface for Software Suspend 2"
+HOMEPAGE="http://www.suspend2.net"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="fbsplash static"
+DEPEND="virtual/libc
+ fbsplash? ( sys-libs/zlib
+ media-libs/freetype
+ media-libs/jpeg
+ media-libs/lcms
+ >=media-libs/libmng-1.0.5
+ media-libs/libpng )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-remove-debug.patch"
+ epatch "${FILESDIR}/${P}-syscall.patch"
+}
+
+src_compile() {
+ # allow for static linking for use in initramfs/initrd
+ use static && LDFLAGS="${LDFLAGS} -static"
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ suspend2ui_text || die "emake suspend2ui_text failed"
+
+ if use fbsplash; then
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ fbsplash || die "emake fbsplash failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ suspend2ui_fbsplash || die "emake suspend2ui_fbsplash failed"
+ fi
+}
+
+src_install() {
+ into /
+ dosbin suspend2ui_text
+ use fbsplash && dosbin suspend2ui_fbsplash
+
+ dodoc AUTHORS ChangeLog KERNEL_API README TODO USERUI_API
+}
+
+pkg_postinst() {
+ if use fbsplash; then
+ einfo
+ einfo "You must create a symlink from /etc/splash/suspend2"
+ einfo "to the theme you want suspend2ui_fbsplash to use, e.g.:"
+ einfo
+ einfo " # ln -sfn /etc/splash/emergence /etc/splash/suspend2"
+ fi
+
+ einfo
+ einfo "Please see /usr/share/doc/${PF}/README.gz for further"
+ einfo "instructions."
+ einfo
+}