summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-03-10 19:29:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-03-10 19:29:06 +0000
commita28dc314f04520f1e06e294f35beffbca5a3910f (patch)
treecc269f31a044cf0cd3420df31e9858104d3f77a5 /sys-apps/smartmontools
parentStable on ppc64; bug #212362 (diff)
downloadgentoo-2-a28dc314f04520f1e06e294f35beffbca5a3910f.tar.gz
gentoo-2-a28dc314f04520f1e06e294f35beffbca5a3910f.tar.bz2
gentoo-2-a28dc314f04520f1e06e294f35beffbca5a3910f.zip
Add USE=minimal support for setups without the smartd.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-apps/smartmontools')
-rw-r--r--sys-apps/smartmontools/ChangeLog8
-rw-r--r--sys-apps/smartmontools/smartmontools-5.37-r1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-apps/smartmontools/ChangeLog b/sys-apps/smartmontools/ChangeLog
index 52f6b73e148f..a2c3ee977949 100644
--- a/sys-apps/smartmontools/ChangeLog
+++ b/sys-apps/smartmontools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/smartmontools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.73 2008/02/07 12:44:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/ChangeLog,v 1.74 2008/03/10 19:29:06 robbat2 Exp $
+
+*smartmontools-5.37-r1 (10 Mar 2008)
+
+ 10 Mar 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +smartmontools-5.37-r1.ebuild:
+ Add USE=minimal support for setups without the smartd.
07 Feb 2008; Raúl Porcel <armin76@gentoo.org> smartmontools-5.37.ebuild:
alpha/ia64 stable
diff --git a/sys-apps/smartmontools/smartmontools-5.37-r1.ebuild b/sys-apps/smartmontools/smartmontools-5.37-r1.ebuild
new file mode 100644
index 000000000000..94a0f4a42b0b
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.37-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.37-r1.ebuild,v 1.1 2008/03/10 19:29:06 robbat2 Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="static minimal"
+
+RDEPEND=""
+DEPEND=""
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dosbin smartctl || die "dosbin smartctl"
+ dodoc AUTHORS CHANGELOG NEWS README TODO WARNINGS
+ doman smartctl.8
+ if ! use minimal; then
+ dosbin smartd || die "dosbin smartd"
+ doman smartd*.[58]
+ newdoc smartd.conf smartd.conf.example
+ docinto examplescripts
+ dodoc examplescripts/*
+ rm -f "${D}"/usr/share/doc/${PF}/examplescripts/Makefile*
+
+ insinto /etc
+ doins smartd.conf
+
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+ fi
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog "You need the 'mail' command if you configured smartd to send reports"
+ elog "via email, 'emerge virtual/mailx' to get a mailer"
+ fi
+}