summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-01-15 08:42:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-01-15 08:42:34 +0000
commit2f82e74edb12fb9122574e036413803f9c50caad (patch)
tree15450190a57ac35ef2ecf81406166045afc6af99 /sys-apps/setserial/setserial-2.17-r4.ebuild
parentAdd pkgconfig dep, bug #205757; use latest automake (diff)
downloadgentoo-2-2f82e74edb12fb9122574e036413803f9c50caad.tar.gz
gentoo-2-2f82e74edb12fb9122574e036413803f9c50caad.tar.bz2
gentoo-2-2f82e74edb12fb9122574e036413803f9c50caad.zip
Implement stty keyword per bug #103423.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-apps/setserial/setserial-2.17-r4.ebuild')
-rw-r--r--sys-apps/setserial/setserial-2.17-r4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/setserial/setserial-2.17-r4.ebuild b/sys-apps/setserial/setserial-2.17-r4.ebuild
new file mode 100644
index 000000000000..9a58edbd70ec
--- /dev/null
+++ b/sys-apps/setserial/setserial-2.17-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/setserial/setserial-2.17-r4.ebuild,v 1.1 2008/01/15 08:42:34 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Configure your serial ports with it"
+HOMEPAGE="http://setserial.sourceforge.net/"
+SRC_URI="ftp://tsx-11.mit.edu/pub/linux/sources/sbin/${P}.tar.gz
+ ftp://ftp.sunsite.org.uk/Mirrors/tsx-11.mit.edu/pub/linux/sources/sbin/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-spelling.patch
+ epatch "${FILESDIR}"/${P}-manpage-updates.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ econf || die
+ emake setserial || die
+}
+
+src_install() {
+ doman setserial.8
+ into /
+ dobin setserial || die
+
+ insinto /etc
+ doins serial.conf
+ newinitd "${FILESDIR}"/serial-2.17-r4 serial
+
+ dodoc README
+ docinto txt
+ dodoc Documentation/*
+}