summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-03 08:58:00 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-03 08:58:00 +0000
commitcaecbd59941b4595161a7df520d13a19a0fa7c4a (patch)
treeff6a270109b8e01528b593fe4b5bc105ca5fd73e /sys-apps/sed
parentout with the old ! (Manifest recommit) (diff)
downloadgentoo-2-caecbd59941b4595161a7df520d13a19a0fa7c4a.tar.gz
gentoo-2-caecbd59941b4595161a7df520d13a19a0fa7c4a.tar.bz2
gentoo-2-caecbd59941b4595161a7df520d13a19a0fa7c4a.zip
sed needs sed no more ! 40786
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/ChangeLog6
-rw-r--r--sys-apps/sed/sed-4.0.9.ebuild16
-rw-r--r--sys-apps/sed/sed-4.1.2.ebuild16
3 files changed, 35 insertions, 3 deletions
diff --git a/sys-apps/sed/ChangeLog b/sys-apps/sed/ChangeLog
index 22f2e4e23caa..b4a9af09a4bf 100644
--- a/sys-apps/sed/ChangeLog
+++ b/sys-apps/sed/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/sed
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.58 2004/09/22 03:42:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.59 2004/10/03 08:58:00 vapier Exp $
+
+ 03 Oct 2004; Mike Frysinger <vapier@gentoo.org> sed-4.0.9.ebuild,
+ sed-4.1.2.ebuild:
+ Make sure sed can compile even if system sed is broken #40786 by Brian Harring.
*sed-4.1.2 (21 Sep 2004)
diff --git a/sys-apps/sed/sed-4.0.9.ebuild b/sys-apps/sed/sed-4.0.9.ebuild
index bbbaca120b29..44cd8f84c623 100644
--- a/sys-apps/sed/sed-4.0.9.ebuild
+++ b/sys-apps/sed/sed-4.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.24 2004/10/03 07:38:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.25 2004/10/03 08:58:00 vapier Exp $
inherit gnuconfig flag-o-matic
@@ -24,6 +24,15 @@ src_unpack() {
}
src_compile() {
+ # make sure system-sed works #40786
+ export NO_SYS_SED=""
+ if ! which sed >& /dev/null ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed ${T}/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ fi
+
local myconf=""
if use macos || use ppc-macos ; then
myconf="--program-prefix=g"
@@ -32,12 +41,17 @@ src_compile() {
$(use_enable nls) \
${myconf} \
|| die "Configure failed"
+ if [ ! -z "${NO_SYS_SED}" ] ; then
+ make clean || die "couldnt clean"
+ fi
use static && append-ldflags -static
emake LDFLAGS="${LDFLAGS}" || die "build failed"
}
src_install() {
+ [ ! -z "${NO_SYS_SED}" ] && export PATH="${PATH}:${T}"
+
into /
dobin sed/sed || die "dobin"
if ! use build
diff --git a/sys-apps/sed/sed-4.1.2.ebuild b/sys-apps/sed/sed-4.1.2.ebuild
index 17e8b3a901ff..884a5870f9b6 100644
--- a/sys-apps/sed/sed-4.1.2.ebuild
+++ b/sys-apps/sed/sed-4.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.2.ebuild,v 1.3 2004/10/03 07:38:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.2.ebuild,v 1.4 2004/10/03 08:58:00 vapier Exp $
inherit gnuconfig flag-o-matic
@@ -24,6 +24,15 @@ src_unpack() {
}
src_compile() {
+ # make sure system-sed works #40786
+ export NO_SYS_SED=""
+ if ! which sed >& /dev/null ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed ${T}/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ fi
+
local myconf=""
if use macos || use ppc-macos ; then
myconf="--program-prefix=g"
@@ -32,12 +41,17 @@ src_compile() {
$(use_enable nls) \
${myconf} \
|| die "Configure failed"
+ if [ ! -z "${NO_SYS_SED}" ] ; then
+ make clean || die "couldnt clean"
+ fi
use static && append-ldflags -static
emake LDFLAGS="${LDFLAGS}" || die "build failed"
}
src_install() {
+ [ ! -z "${NO_SYS_SED}" ] && export PATH="${PATH}:${T}"
+
into /
dobin sed/sed || die "dobin"
if ! use build