summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-16 13:48:16 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-16 13:48:16 +0000
commitb52b4eddd8a6e5185c2d5cc0607b5af5345f8da5 (patch)
tree7dedc83c1022fb3de703f3867ad58f6f1aa77dcf /sys-apps/sed/sed-4.0.9.ebuild
parentVersion bumped. Memory leak fixed and bug submitted by the fabulous Luke Mack... (diff)
downloadgentoo-2-b52b4eddd8a6e5185c2d5cc0607b5af5345f8da5.tar.gz
gentoo-2-b52b4eddd8a6e5185c2d5cc0607b5af5345f8da5.tar.bz2
gentoo-2-b52b4eddd8a6e5185c2d5cc0607b5af5345f8da5.zip
Fixed use invocation; bug #64260.
Diffstat (limited to 'sys-apps/sed/sed-4.0.9.ebuild')
-rw-r--r--sys-apps/sed/sed-4.0.9.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/sys-apps/sed/sed-4.0.9.ebuild b/sys-apps/sed/sed-4.0.9.ebuild
index db8c2d53ce8a..8623b4382540 100644
--- a/sys-apps/sed/sed-4.0.9.ebuild
+++ b/sys-apps/sed/sed-4.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.18 2004/09/16 02:23:44 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.19 2004/09/16 13:48:16 usata Exp $
inherit gnuconfig
@@ -45,8 +45,6 @@ src_install() {
fi
rm -f ${D}/usr/bin/sed
- use macos && cd ${D} && for x in `find . -name 'sed*' -print`; do mv "$x" "${x//sed/gsed}"; done && cd ${WORKDIR}/${P}
- use macos && dosym ../../bin/gsed /usr/bin/gsed || dosym ../../bin/sed /usr/bin/sed
- use ppc-macos && cd ${D} && for x in `find . -name 'sed*' -print`; do mv "$x" "${x//sed/gsed}"; done && cd ${WORKDIR}/${P}
- use ppc-macos && dosym ../../bin/gsed /usr/bin/gsed || dosym ../../bin/sed /usr/bin/sed
+ ( use macos || use ppc-macos ) && cd ${D} && for x in `find . -name 'sed*' -print`; do mv "$x" "${x//sed/gsed}"; done && cd ${WORKDIR}/${P}
+ ( use macos || use ppc-macos ) && dosym ../../bin/gsed /usr/bin/gsed || dosym ../../bin/sed /usr/bin/sed
}